Results 1 to 3 of 3
  1. #1
    Master Untangler
    Join Date
    Oct 2008
    Posts
    141

    Default Untangle webinterface hangs when importing SSL certificate

    Hi guys. I was renewing my certificate but after pasting the server certificate and the intermediate certificate and pressing proceed, The interface hangs at "Importing interface". I'm using digicert as my authority.

    Now i can't even log on via another browser.

    Traffic is passing normally, but i'm not sure if it's filtering anything anymore. Anyways, What should I do? Reboot?

  2. #2
    Master Untangler
    Join Date
    Oct 2008
    Posts
    141

    Default

    I've rebooted but i still can't access the web interface. I know webservers usually don't start when there is an certificate error. But i'm not sure how i'm supposed to deal with this. :/

    When I connect to the server with a monitor it just says Input not supported. I've tried two different monitors and both have the same result. I also tried restarting x-server with ctrl alt backspace, but didn't do a thing.
    Last edited by arndawg; 06-23-2010 at 01:42 AM.

  3. #3
    Master Untangler
    Join Date
    Oct 2008
    Posts
    141

    Default

    I currently have SSH access, so can anyone help me on what to do to get the web-interface going again?

    edit:

    I get this from the logs when restarting apache2

    [Wed Jun 23 10:19:56 2010] [error] SSL Library Error: 218710120 error:0D094068:asn1 encoding routines:d2i_ASN1_SET:bad tag
    [Wed Jun 23 10:19:56 2010] [error] SSL Library Error: 218529960 error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
    [Wed Jun 23 10:19:56 2010] [error] SSL Library Error: 218595386 error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error
    [Wed Jun 23 10:19:56 2010] [error] SSL Library Error: 218734605 error:0D09A00D:asn1 encoding routines:d2i_PrivateKey:ASN1 lib
    [Wed Jun 23 19:53:41 2010] [warn] No JkShmFile defined in httpd.conf. Using default /var/log/apache2/jk-runtime-status
    [Wed Jun 23 19:53:41 2010] [error] Init: Private key not found
    [Wed Jun 23 19:53:41 2010] [error] SSL Library Error: 218710120 error:0D094068:asn1 encoding routines:d2i_ASN1_SET:bad tag
    [Wed Jun 23 19:53:41 2010] [error] SSL Library Error: 218529960 error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
    [Wed Jun 23 19:53:41 2010] [error] SSL Library Error: 218595386 error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error
    [Wed Jun 23 19:53:41 2010] [error] SSL Library Error: 218734605 error:0D09A00D:asn1 encoding routines:d2i_PrivateKey:ASN1 lib
    So that means something got bugged while creating a CSR. Now, how to do this manually?

    edit2:
    Okay i got the apache instance running again by renaming the /etc/apache2/ssl/apache.pem, and then using the apache.pem.old .. then i ran /etc/init.d/apache2 restart, and it started working again. Now i'll just have to try this CSR again.. grr
    edit3:
    Happy camper. Everything is working. Pasted the certificates from IE, not chrome, and this time it worked. Might have nothing to do with the browser, but you never know. Perhaps some charset issue. Anyways, happy camper.
    Last edited by arndawg; 06-23-2010 at 11:11 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2