Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Untanglit
    Join Date
    Nov 2009
    Location
    Berlin, Berlin
    Posts
    29

    Default Permission denied (publickey,gssapi-with-mic).

    Hi guys,

    Anyone know what this means: Permission denied (publickey,gssapi-with-mic).

    I am trying to ssh in and configured it to start every time I restart Untangle. Almost looked liked there was a local permission error but set the local file to 777 for testing and still same problem.

    Anyone have any ideas?

    TIA
    Petter

  2. #2
    some dude hlarsen's Avatar
    Join Date
    Jul 2010
    Location
    sfba
    Posts
    1,386

    Default

    did you use ssh-copy-id or something?
    are you connecting as root@ip?
    Attention: Support on the Untangle Forums is provided by volunteers and community members.
    If you need official Untangle support please call or email support@untangle.com.

  3. #3
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Mateo, CA
    Posts
    13,069

    Default

    if you set authorized_keys to 777 sshd will ignore it.
    It must have the correct permissions. (700 or 600)
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  4. #4
    Untanglit
    Join Date
    Nov 2009
    Location
    Berlin, Berlin
    Posts
    29

    Default

    Quote Originally Posted by hlarsen View Post
    did you use ssh-copy-id or something?
    are you connecting as root@ip?
    No, nothing like that, only started SSH like described in the wiki.

    Yes, connecting with root.

    Thanks
    Petter

  5. #5
    Untanglit
    Join Date
    Nov 2009
    Location
    Berlin, Berlin
    Posts
    29

    Default

    Quote Originally Posted by dmorris View Post
    if you set authorized_keys to 777 sshd will ignore it.
    It must have the correct permissions. (700 or 600)
    Petters-MacBook-Pro:~ petter$ chmod -R 700 .ssh/
    Petters-MacBook-Pro:~ petter$ ssh root@10.0.0.1
    Permission denied (publickey,gssapi-with-mic).
    Petters-MacBook-Pro:~ petter$

    Still generating the same error.

    Thanks
    Petter

  6. #6
    Untanglit
    Join Date
    Nov 2009
    Location
    Berlin, Berlin
    Posts
    29

    Default

    Tried putty and the following message appears:

    Disconnected: No supported authentication methods available (server sent: publickey,gssapi-with-mic)

  7. #7
    some dude hlarsen's Avatar
    Join Date
    Jul 2010
    Location
    sfba
    Posts
    1,386

    Default

    so what exactly did you do on the Untangle to try and get this working, and what did you do to your computer?

    all you need to do is get sshd running on Untangle, use ssh-copy-id to copy your credentials to it, then connect with ssh. in any case, i think it should be asking you for a password even if your key is wrong unless you disabled password authentication.
    Last edited by hlarsen; 08-08-2011 at 02:23 PM. Reason: i think
    Attention: Support on the Untangle Forums is provided by volunteers and community members.
    If you need official Untangle support please call or email support@untangle.com.

  8. #8
    Untanglit
    Join Date
    Nov 2009
    Location
    Berlin, Berlin
    Posts
    29

    Default

    Quote Originally Posted by hlarsen View Post
    so what exactly did you do on the Untangle to try and get this working, and what did you do to your computer?

    all you need to do is get sshd running on Untangle, use ssh-copy-id to copy your credentials to it, then connect with ssh. in any case, i think it should be asking you for a password even if your key is wrong unless you disabled password authentication.
    1. Installed untangle
    2. Launched terminal after install and enabled SSH like in the wiki
    3. Try to connect

    That's it!

    Thanks
    Petter

  9. #9
    some dude hlarsen's Avatar
    Join Date
    Jul 2010
    Location
    sfba
    Posts
    1,386

    Default

    just did a fresh install of a UT at 10.168.58.5:

    Code:
    hlarsen@hDesk:~$ ssh root@10.168.58.5
    ssh: connect to host 10.168.58.5 port 22: Connection refused
    no problem. back to the Untangle:

    Code:
    /home/kiosk # rm /etc/ssh/sshd_not_to_be_run
    /home/kiosk # /etc/init.d/ssh start
     * Starting OpenBSD Secure Shell server sshd
    back at the desktop:

    Code:
    hlarsen@hDesk:~$ ssh root@10.168.58.5
    The authenticity of host '10.168.58.5 (10.168.58.5)' can't be established.
    RSA key fingerprint is bl:ah:bl:ah:bl:ah:bl:ah:bl:ah:bl:ah:bl:ah:bl:ah:.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added '10.168.58.5' (RSA) to the list of known hosts.
    root@10.168.58.5's password:
    enter password, logged in, everyone's happy. exit ssh session. then:

    Code:
    hlarsen@hDesk:~$ ssh-copy-id root@10.168.58.5
    root@10.168.58.5's password: 
    Now try logging into the machine, with "ssh 'root@10.168.58.5'", and check in:
    
      ~/.ssh/authorized_keys
    
    to make sure we haven't added extra keys that you weren't expecting.
    
    hlarsen@hDesk:~$ ssh root@10.168.58.5
    Linux hostname.example.com 2.6.26-2-untangle-686 #1 SMP Fri Nov 26 13:36:11 PST 2010 i686
    
    Last login: Thu Jun  2 13:46:49 2011 from 10.168.58.4
    root@hostname#                                                                                                                                                                                                                              ~ #
    no more password prompt - as Kelly Bundy would say, "Viola!"
    Attention: Support on the Untangle Forums is provided by volunteers and community members.
    If you need official Untangle support please call or email support@untangle.com.

  10. #10
    some dude hlarsen's Avatar
    Join Date
    Jul 2010
    Location
    sfba
    Posts
    1,386

    Default

    without more specific info all i can think of is:

    a) you did some other stuff on the Untangle ('cat /root/.zsh_history' will show it all)
    b) your desktop has some specifics settings that are causing this
    c) you're port forwarding 22 to somewhere else
    Attention: Support on the Untangle Forums is provided by volunteers and community members.
    If you need official Untangle support please call or email support@untangle.com.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2