Results 1 to 7 of 7
  1. #1
    Newbie
    Join Date
    Feb 2009
    Location
    Nashville, TN
    Posts
    3

    Default Adblocker....why can't i block these ads? is it Https that is preventing it?

    Good evening Untangle forum and employees! Hope you are enjoying spring wherever you are.

    We are getting reports from our users that they are starting to see inappropriate ads on the sides of sites like youtube. (not the embedded commercial video ads that play before the youtube video plays).

    We thought it was just an error, but were able to duplicate it. Seems that inspecting the source on the page shows that the ad is coming from https://tpc.googlesyndication.com. Yikes.

    We have both "Categorize HTTPS traffic by IP address" & "Categorize HTTPS traffic by SNI (Server Name Indication) information if present" turned on in our webfilter rack.

    • We tried to block it by adding tpc.googlesyndication.com to the adblocker list. that did not work.
    • We added tpc.googlesyndication.com to our web filter list. but that is not Https, so that did not work either.
    • I read in another forum that we we should turn on the marketing category in the web filter, but that did not work either. (which makes sense since it says it won't block ads).
    • We ran a traceroute on googlesyndication.com to get the ip address then added it to the block list manually in webfilter. That did not work.
    • Then we added tpc.googlesyndication.com and http://www.googleadservices.com to the ad blocker list. That did not work.
    • then aded ad.doubleck.net and the ip address to both the ad filter and web filter.


    all of this and the ads still show when we refresh the page on the client's machine. Any ideas?

    is this because ads are delivered over https now? If so....when will https ads be blocked?

    got any other suggestions? i am open to ideas. screenshot attached

    keith

    Capture.PNG

  2. #2
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    For ad blocker to scan HTTPS you need to install and configure SSL Inspector to inspect that traffic.

    Yes, thats a huge PITA just to block ads.
    Refer to warning on Ad Blocker page.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Newbie
    Join Date
    Feb 2009
    Location
    Nashville, TN
    Posts
    3

    Default

    ok....found the answer! Seems that i was supposed to load it in adblocker likin this format:

    *.googlesyndication.com*
    *.doubleclick.net*

    with those loaded, the ad is gone. as seen in the screenshot below. after some browsing, Looks like everything else is still working correctly. good stuff!

    Capture2.PNG

  4. #4
    Newbie
    Join Date
    Feb 2009
    Location
    Nashville, TN
    Posts
    3

    Default

    thanks! i don't see that as an option for the rack...so i am guessing we are too many versions behind. Still on 9.4.2 somehow - even with automatic upgrades turned on. is that why i don't see SSL inspector?

  5. #5
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,241

    Default

    There is no automatic upgrade from 9.x to 10.x, you need to push that box over and reinstall with v12, then reconfigure manually. 9.x is a time bomb at this point... you NEED TO PAVE THAT BOX.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  6. #6
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    9,743

    Default

    Correct. 9.4.2 has been end of life since last year.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  7. #7
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    Quote Originally Posted by worldchanger View Post
    Still on 9.4.2 somehow -
    ouch
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2