Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44
  1. #1
    Newbie
    Join Date
    May 2009
    Posts
    3

    Default Microsoft download manager blocked

    Hey all, hope you guys can help a newb. We've been testing Untangle 6.1 at work, we have 2 servers running on 2 seperate networks, both have this issue. All of the minor problems we've run in to have been solved by searching and reading here but this one's a head scratcher. I went to download the Windows 7 RC, the download manager would pop up and imediatly disconnect. Looking at the Untangle logs pointed to the Spyware Blocker, so I turned it off, no dice, nothing in the log referencing a block after turning it off. Troubleshooting revealed that not only do I need to turn off Spyware Blocker, but also Intrusion Prevension, Virus Blocker, Web Filter, and oddly enough Phish Blocker before it would connect and download. The only service that has anything in it's log is Spyware blocker.

    I tried to post the full log entry but it wouldn't let me as it sees it as a link and I don't have 5 posts, so here's part of it

    view.atdmt.com/action/mrtity_FY09CAREWindows7DownloadsFinal_1 in URL List 65.242.27.33:80

    One server is pretty much "out of the box" no custom filters or settings, so that's the one I'm working with. I went through looking for a rule on atdmt.com and the IP and disabled the only one I found with no luck.

    I figure I have to be missing something obvious but it eludes me.
    Last edited by Davejb; 05-27-2009 at 08:11 AM.

  2. #2
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,510

    Default

    It's a bug in the base untangle. You should have been around when I was posting up a storm and yelling at support while trying to download Exchange 2007. No Rack policies don't help, and bypass rules don't work.

    The only thing that did work was stopping the UVM outright for the duration of the download.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  3. #3
    Newbie
    Join Date
    May 2009
    Posts
    3

    Default

    Quote Originally Posted by sky-knight View Post
    It's a bug in the base untangle. You should have been around when I was posting up a storm and yelling at support while trying to download Exchange 2007. No Rack policies don't help, and bypass rules don't work.

    The only thing that did work was stopping the UVM outright for the duration of the download.
    Well, that's a pretty big bug, explains why I can't figure it out
    Last edited by Davejb; 05-27-2009 at 08:12 AM.

  4. #4
    Untangle Ninja juank's Avatar
    Join Date
    Aug 2007
    Location
    Athens
    Posts
    1,413

    Default

    The way I do it is... I have another RACK where I have my account registered (or IP) where I bypass all the rules... I enable that rack when I have problems with download managers. But... I can fix some download managers just disabling the RESUME FTP feature in the virus blocker (I think it is in the virus blocker config)
    --------------------------------
    Juan Machado
    --------------------------------

  5. #5
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,510

    Default

    I'm going to have to try that one... but again when I went through the nightmare to download Exchange nothing worked short of stopping the UVM. It wouldn't work with all rack modules powered off...

    In theory however you're right, those resume features in the AV rack should be the magic box...
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  6. #6
    Untangler
    Join Date
    Feb 2008
    Posts
    84

    Default

    Microsoft is going to be using this mechanism a lot more in the future and therefore this problem needs to be addressed for one and all.

    Whilst it might sound 'small fry' right now - it won;t for much longer.

    It does not work for me either. the download manager sits there not doing anything. FTP resume did not help.

    Stopping UVM is NOT AN ACCEPTABLE SOLUTION. I am not stoppping untangle so that my network is not protected.

    Solutions please?

  7. #7
    Master Untangler
    Join Date
    Aug 2008
    Posts
    283

    Default

    Quote Originally Posted by norskman View Post
    Microsoft is going to be using this mechanism a lot more in the future and therefore this problem needs to be addressed for one and all.

    Whilst it might sound 'small fry' right now - it won;t for much longer.

    It does not work for me either. the download manager sits there not doing anything. FTP resume did not help.

    Stopping UVM is NOT AN ACCEPTABLE SOLUTION. I am not stoppping untangle so that my network is not protected.

    Solutions please?
    I've used the download managers successfully. I would check not only the FTP resume but also the HTTP Resume...who knows, it might just work.

  8. #8
    Master Untangler
    Join Date
    Aug 2008
    Posts
    939

    Default

    I hate to be the one to say it, but I have never had a problem downloading anything from my MSDN account at Microsoft.

  9. #9
    Newbie
    Join Date
    May 2009
    Posts
    3

    Default

    Quote Originally Posted by datdamnmachine View Post
    I've used the download managers successfully. I would check not only the FTP resume but also the HTTP Resume...who knows, it might just work.
    Tried that, no go.

  10. #10
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,510

    Default

    I just logged into my eopen account to see if anything changed...

    Went and tried to download the Exchange 2007 Server Standard Edition SP1 DVD ISO. Installed the akamai download manager required to get the file... and it instafails with a status of "error".

    If I turn off the following rack modules... it works.

    Phish Blocker
    Spyware Blocker
    Web Filter
    Virus Blocker
    Intrusion Prevention

    Mind you NONE of these modules report anything being blocked to break anything while I'm hammering the resume button.

    To be honest the "fix" I had last go around was to hit the off button for the attack blocker, because that forces a reset of the UVM. Then while it was powering off... hit resume until the download manager connects. Then I can turn everything back on and life is good until I need to restart a download.

    Annoying... but I don't download from Microsoft much so I've been quiet about it. And yes, I do have e-mails going to untangle support on this issue MONTHS ago with TCPDUMPs full of traffic. I got no response. And to be fair, I forgot about it.

    P.S. I've had HTTP and FTP resume enabled for ages.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2