Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 41
  1. #11
    Untanglit
    Join Date
    Jul 2015
    Posts
    16

    Default

    We're having this problem too since last week. We're on 12.1 and we have a http only landing page where the user has to mark a check box to agree to our terms and conditions only.
    Once he checks the box it is becoming unchecked again instead of redirecting the user to his start page.

    @Stamp : You are right about the loop, it is the same here. We can shortly fix it with a reboot

    Clues anyone ?
    Last edited by thafener; 08-09-2016 at 07:17 AM.

  2. #12
    Untangle Ninja
    Join Date
    Feb 2016
    Posts
    1,135

    Default

    Regrettably, I don't use the Captive Portal app so I can't tinker, but I can say that I have experienced captive portal problems exactly as described (the looping) with another product, and that seemed to be cookie related. So as a long shot, does anything change if you clear cookies?

  3. #13
    Untangler
    Join Date
    Aug 2014
    Posts
    47

    Default

    I don't know, probably nothing as it happened on multiple browsers on the same device and we'll, personally I had the cookie not enabled

  4. #14
    Untangler
    Join Date
    Aug 2014
    Posts
    47

    Default

    Re-reading that gives me goosebumps, so I'l write it in a way that makes sense

    I haven't tested the looping with cookie clearing because the issue appeared on different browsers (with no shared cookies), moreover I didn't set the portal to use a cookie for authentication so I doubt it has anything to do with it.

  5. #15
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    i wonder if the browser is caching the 301 redirect (even though it says not to)

    this would mean you login, then you click agree or whatever, it sends you back to the original page, and it incorrectly uses the cached 301 redirect and goes back to the capture page.
    You can test this by just hard-coding the redirect url to something unique after login.

    You can test this by setting the "Redirect URL" in captive portal > captive page
    to something like "http://untangle.com"
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  6. #16
    Untanglit
    Join Date
    Jul 2015
    Posts
    16

    Default

    We are using a Redirect URL redirecting to our company website but I have changed to http://untangle.com for testing purposes but this
    had no impact on the issue.
    Before I made shure to clear chache and delete cookies.
    And yes, you're checking "Agree" and hit "Continue" and the agree checkbox becomes unchecked and there is no successful authentification.

  7. #17
    Untangle Ninja
    Join Date
    Feb 2016
    Posts
    1,135

    Default

    That's really odd. My only experience with the Untangle captive portal was months ago, during testing and deployment trials, and it worked as expected back then.

    What are possible problem spots if not cache, cookies, or JavaScript?

  8. #18
    Untangler
    Join Date
    Aug 2014
    Posts
    47

    Default

    Quote Originally Posted by Sam Graf View Post
    That's really odd. My only experience with the Untangle captive portal was months ago, during testing and deployment trials, and it worked as expected back then.
    I've been running it like a charm for probably one year, it was the 12.1 update that didn't really play nice.

    That said it looks like there's been a small update because today everybody got logged out and, at first sight, it looks like it's working again. If anybody complains I'll let you know, but for the moment I'd say good job for solving the issue

  9. #19
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    Unfortunately, there were no changes to captive portal in the latest update.
    (nor in 12.1 as a whole actually).

    No known issues yet.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  10. #20
    Untangler
    Join Date
    Aug 2014
    Posts
    47

    Default

    This worries me a bit. So basically it's a random bug or corner case that can appear and go away seemingly random?

Page 2 of 5 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2