Results 1 to 3 of 3
  1. #1
    Untangler
    Join Date
    Nov 2016
    Location
    Grafton, Australia
    Posts
    33

    Default Intermittent issue - API Events stop for single users

    We've been using UT for several years, with about 100 active students in a Winserv 2008 R1 / Win 7 workstation environment.

    About once per week, a random single user will get bumped into the DEFAULT rack, and I've traced this back to the API Notification events in Directory Connector not being received for that one user - all other users continue to work OK.

    We run AD Connector, and the UT AD Logon script is run from GPO via a local SYSVOL. I assume that the script is stopping for some reason, and our users can't manually stop scripts. I wonder if any timeouts inside the While True loop in the script might be stopping the script.

    Any hints on how to diagnose where the script is terminating ?
    Last edited by Pilotpak; 05-17-2018 at 12:38 AM.

  2. #2
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    24,039

    Default

    Honestly, I'd stop using the script and start using the AD Logon monitor, it's far more reliable. Why have a script running on every station when you can just have the event logs on your DC tell Untangle where your people are?
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  3. #3
    Untangler
    Join Date
    Nov 2016
    Location
    Grafton, Australia
    Posts
    33

    Default

    OK Thx. I had a quick look at the monitor and we'll give it a go and see if it's an improvement on the script. I guess it should be an easy backout / revert should it not be successful.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2