Results 1 to 7 of 7
  1. #1
    Untanglit
    Join Date
    Jun 2008
    Posts
    15

    Default A small bug that may cause big problems

    Hello everybody.

    It seems i've found a bug in the port forwarding mechanism. If Untangle dislikes some forwarding rule for some reason, it doesn't say anything and just turns this rule off.

    Here's my situation. I've had a rule that forwarded some ports, defined as a list of numbers, delimitted my commas, for example:

    Code:
    21,25,110
    Then, there was a need of adding some range of ports to forward, so i've modified a rule, and it started looking like:

    Code:
    21,25,110,1024-1032
    Then, all forwardings defined by this rule (e.g. for 21,25 and 110 port) had been turned off.

    When i started to investigate this incident, i've found that Untangle says nothing even if i write some random text in port forwarding rule. It just accepts it without alerting about any problems.

    Well, it is not a major issue, but it could cause some troubles if the rules are not tested after modifying.

    Post Scriptum. I know it is a good practice to create a separate rules for every port that should be forwarded. Well, it is my mistake. But anyway, it seems to be good if Untangle will check the rules' arguments.

    p.p.s. I am sorry for my not very good english...

  2. #2
    Untangler geniehost's Avatar
    Join Date
    Jun 2008
    Posts
    72

    Default

    Hello there,

    Do you mean the port forward works with you? I am trying to do port forward and no succeed since I used UT, I need to access my PC with Remote-Desktop but I cannot!

    Please see my post in this thread for more details : http://forums.untangle.com/showthread.php?t=3430

    Regards,
    Genie

  3. #3
    mdh
    mdh is offline
    Untangle Ninja mdh's Avatar
    Join Date
    Aug 2007
    Posts
    4,752

    Default

    ItsOnlyMe...I have experimented with rules and have found that ports separated by commas in the SAME rule as ports that are separated by hyphens don't get along well together. Put 21,25,110 in one rule and 1024-1032 in another and you should be fine.

  4. #4
    mdh
    mdh is offline
    Untangle Ninja mdh's Avatar
    Join Date
    Aug 2007
    Posts
    4,752

    Default

    geniehost...If its a Windows box, have you checked whether the specific firewall setting for RDP is allowing your connection?

  5. #5
    Untangler geniehost's Avatar
    Join Date
    Jun 2008
    Posts
    72

    Default

    Quote Originally Posted by mdh View Post
    geniehost...If its a Windows box, have you checked whether the specific firewall setting for RDP is allowing your connection?
    No problems with the windows box, it was working fine before UT, and even if I disconnect UT and use only the ADSL router the forward works, I check the log and I find nothing rejected in UT - very strange

  6. #6
    Untangler geniehost's Avatar
    Join Date
    Jun 2008
    Posts
    72

    Smile

    Good news,

    Port forward works, I just go to Protocols Control and tick on RDP <Log>

    and now everything works

    regards,
    Genie

  7. #7
    Untanglit
    Join Date
    Jun 2008
    Posts
    15

    Default

    Quote Originally Posted by mdh View Post
    ItsOnlyMe...I have experimented with rules and have found that ports separated by commas in the SAME rule as ports that are separated by hyphens don't get along well together. Put 21,25,110 in one rule and 1024-1032 in another and you should be fine.
    Thank you for your answer!

    I've already fugured out the same result and have no problem (moreover, i've created separate rules for every port or port range i want to forward). I just want to warn the other Untangle users that there is a potential problem and to tell Untangle developers that a kind of rule arguments check should be very good.

    Quote Originally Posted by geniehost View Post
    Hello there,

    Do you mean the port forward works with you? I am trying to do port forward and no succeed since I used UT, I need to access my PC with Remote-Desktop but I cannot!
    I've seen that you've solved this problem but i'll write the answer anyway. There are three things you should do to forward a port in Untangle:
    1) create a port forwarding rule;
    2) if necessary, create a firewall rule which will allow packets to go through port forwarding mechanism;
    3) if necessary, create a protocol control rule which will allow the protocol that should be forwarded to go through port forwarding mechanism.

    If one of these things fails, the port forwarding will not work. So, if something goes wrong, do the check of list above and everythings will go fine

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2