Announcement

Collapse
No announcement yet.

xen and untangle

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • xen and untangle

    does untangle 5.1 installs as a guest on xenserver 4.1? I have gone through some previous posts, can somebody help me with the installaton please!

  • #2
    Someone with Xen background may be able to help, but Untangle is not supported on any virtual platform except VMware.

    Comment


    • #3
      xen

      I can see no reason that untangle wouldn't work fine on XEN. It runs a modern kernel that is newer than the XEN DomU inclusion. You should be able to setup a Dom0 and build a DomU XEN quite easily.

      I might suggest that you start with an ubuntu 8.04 server build. Install something like "apt-get install xfce4 ubuntu-xen-server virt-manager"

      now you can launch virt-manager and install an ubuntu 8.04 in the xen domU, then install untangle lite. I suggest that you dedicate a few ethernet interfaces to the net untagle VM instead of doing to much bridging.

      good luck

      Comment


      • #4
        If someone does try this - please write down the steps!
        I'd like to give it a try also.

        dadenson: welcome to the forums!
        Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
        If you need Untangle support please call or email [email protected]

        Comment


        • #5
          You should be able to install Untangle in a HVM domU without any problems. I have seen some posts on the xen-users mailing list from someone that has.

          This past weekend I managed to install Untangle in a paravirtual domU on my Xen box and it's now protecting my network. The most difficult part of the whole operation was compiling a kernel with the required Untangle patches and Xen support.

          Here's a quick break down of what I did:
          1. Install a 32bit Etch domU.
          2. Install Untangle Lite as documented on the wiki.
          3. Download Untangle Etch kernel (2.6.22) from subversion repository.
          4. Manually patch kernel with Debian's Xen patches (in debian/binary-custom.d/xen/patchset/).
          5. Manually patch kernel with Untangle's patches (in patches/).
          6. Enable xen frontend in kernel config.
          7. Enable required Untangle options in kernel config (CONFIG_NFNETLINK_COPY_UNTANGLE_MODE=y).
          8. Reboot and configure Untangle via Xen framebuffer (VNC).

          Some problems I ran into:
          * Initially tried this on 64bit CentOS Xen 3.1 dom0. It didn't really like running a 32bit domU (lots of Untangle kernel crashes) so I switched to a Hardy dom0 which has Xen 3.2. Has been running smoothly ever since.
          * Couldn't get a Xen framebuffer with a resolution better than 800x600 so initial setup required moving the Untangle client window around a bit.
          * untangle-vm takes forever to start if your kernel doesn't have the required Untangle patches. While testing kernel's I would suggest turning this off at boot.


          Hope this helps someone.

          Comment


          • #6
            Converting the VMware VM to Xen VM?

            Hello,

            I also want to try and get untangle running on XenServer (the commercial product) instead of VMware. I am going to try the approach of downloading the VMware Appliance from Untangle (here) and then running the Xen v2v utility V2VXA to convert the VMware appliance to a Xen appliance.

            Instructions on using the V2VXA utility to convert VMware appliances are here.

            Following the instructions, I was able to run the conversion program just fine. Tomorrow, I will try to import the converted VM into my XenServer Enterprise system.

            Brian

            Comment


            • #7
              No Dice

              To reply to my earlier post, I didn't have any luck getting Untangle to work properly. I went through a "standard" vm conversion process with the VMware appliance and it didn't get the mouse to work. What I did was:
              1. Download the VMware appliance
              2. Bring up the VMware appliance in VMware Workstation (in which the mouse and keyboard work fine)
              3. Go through the configuration wizard
              4. Uninstall the vmware-tools software
              5. Shutdown the VM
              6. Convert the VM to XenServer format
              7. Import the VM into XenServer
              8. Start it up
              9. Still no mouse and very limited keyboard control


              Everything seemed to work fine. The conversion process worked great (no errors), the Xen import process worked great (no errors), I just can't get the mouse and keyboard to work properly! Very frustrating.

              I am not anxious to go through the process Scott suggested, patching the kernel et al.

              Comment


              • #8
                I just made an attempt to run UT on paravirtualized xen domU. I started with Debian etch 32bit install and have UT-lite installed as per the Debian - install wiki. I can ssh into the domU and it appears that the system is running:

                root 1513 1 0 Sep13 ? 00:00:00 dhclient3 -pf /var/run/dhclient.eth1.pid -lf /var/lib/dhcp3/dhclient.eth1.leases eth1
                root 1823 1 0 Sep13 ? 00:00:00 /sbin/syslogd
                root 1829 1 0 Sep13 ? 00:00:00 /sbin/klogd -x
                root 1845 1 0 Sep13 ? 00:00:00 /usr/sbin/slapd -h ldap://127.0.0.1:3899 -f /etc/untangle-ldap/slapd.conf
                root 1909 1908 0 Sep13 ? 00:00:00 hald-runner
                root 1982 1 0 Sep13 ? 00:00:00 /usr/sbin/sshd
                root 2000 1 0 Sep13 ? 00:03:11 /usr/bin/ruby1.8 /usr/bin/mongrel_rails start -S /var/lib/rails/untangle-net-alpaca/root-handler.conf -c /var/lib/rails/untangle-net-alpaca -e production -a 127.0.0.1 --prefix /alpaca -d -l /var/log/untangle-net-alpaca/mongrel.log --pid /var/run/untangle-net-alpaca/mongrel.pid
                root 2208 2198 0 Sep13 ? 00:00:00 /usr/sbin/ntpd -p /var/run/ntpd.pid -u 107:109 -g
                root 2216 1 0 Sep13 ? 00:00:00 /usr/sbin/cron
                root 2243 1 0 Sep13 ? 00:00:17 /bin/bash /usr/bin/uvm.sh -Dcom.untangle.uvm.memmonitor.enabled=true -Dje.maxMemory=32 -Dnetworkaddress.cache.ttl=30 -Dsun.net.inetaddr.ttl=30 -Dnetworkaddress.cache.negative.ttl=10
                root 6083 1 0 Sep13 ? 00:00:00 Xrealvnc :1 -desktop X -auth /root/.Xauthority -rfbwait 120000 -rfbauth /root/.vnc/passwd -rfbport 5901 -fp /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi -co /etc/X11/rgb
                root 6114 1 0 Sep13 ? 00:00:00 /usr/bin/dbus-launch --exit-with-session x-session-manager
                root 6115 1 0 Sep13 ? 00:00:00 /usr/bin/dbus-daemon --fork --print-pid 4 --print-address 6 --session
                root 1948 1 0 Sep13 tty1 00:00:00 /sbin/getty 38400 tty1
                root 18678 1982 0 12:26 ? 00:00:00 sshd: [email protected]/0
                root 18680 18678 0 12:26 pts/0 00:00:00 -bash
                root 25955 1 0 12:32 ? 00:00:00 /usr/sbin/gdm
                root 6058 2243 0 12:41 ? 00:00:00 sleep 2
                root 6059 18680 0 12:41 pts/0 00:00:00 ps -ef
                root 6060 18680 0 12:41 pts/0 00:00:00 grep root

                However I can not configure UT. I tried VNC and can not connect to the system. Can not connect via http or https either.


                I looked over Scott's post above and could not find just the untangle 2.6.22 etch kernel source to try and compile new kernel. Is it included if I grab the entire source install for UT?

                Scott if youre still out there any pointers as to how you accomplished this would be greatly appreciated.

                regards,

                mjs

                Comment


                • #9
                  I obtained full trunk from svn, hopefully can get a kernel patched and installed. Very new to UT as well as Xen so any tips are appreciated. I will be tinkering with this over the next few days. If I work it out I will post my details.

                  mjs

                  Comment


                  • #10
                    Are people interested in getting UT running under Xen doing so primarily to test UT or to actually deploy UT into a production environment?

                    Cheers,
                    Kermee

                    Comment


                    • #11
                      We tested this for production, but had similar installation/configuration issues - at this point we'd really like to see HyperV compatibility...

                      Comment


                      • #12
                        HyperV Compatibility

                        I have successfully deployed Untangle in a Hyper-V (TEST!) environment. One of the initial challenges was that the keyboard would work but not the mouse. To get around this I installed untangle on a standalone unit, configured remote accessibility and created the shell password. I then used a network drive imaging tool to image a Hyper-V drive. I then booted the machine and was able to do what configurations I needed for the proper network config by launching firefox or by the command line itself, I can't remember which. (Note that you must use legacy network adapters in Hyper-v)

                        It took some toying but finally I was able to view the application from a remote machine.

                        --Adam

                        Comment


                        • #13
                          Let us know, how it goes. We are working with the VMWare deployment right now, but would prefer HyperV for simplicity and performance...

                          Comment


                          • #14
                            I've been running Untangle 5.3 for about 3 months now on my Ubuntu Xen 3.1 server. I've had some problems and it could work better. The biggest problem is that I can't use more than one vcpu.
                            But still, it's there and working quite ok. I hope it will work better with Intrepid and Untangle 6.0. And if there ever will be a CLI installation and configuration for Untangle and the possibility to run it without QEMU, that would be great. I think that QEMU is screwing somewhat with the kernels or something.. Dunno.
                            But if you would like, I could try to write down what I've done...

                            Comment


                            • #15
                              JPenrose: How big of a scale are you talking about as far as Hyper-V goes (how many supported machines)?

                              Comment

                              Working...
                              X