Results 1 to 9 of 9
  1. #1
    Untangler
    Join Date
    Jun 2008
    Posts
    50

    Default Linux Newbie SSH Issue

    I'm trying to get SSH running on my Untangle server. When I try to connect from a machine inside my network, I get a "connection refused" error. I have searched on this forum and found a few things, but the answers were obviously given by and to people who know Linux pretty well. One tip I did see that I liked was changing the Listen Address to that of the gateway for my network, which I've done. However, when I re-start, I get a message that states something like "not_to_be_run". I'm wondering if there are some additional setup steps that I need to go through, and if so, what are they?

    Thanks,
    Jesse

  2. #2
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,049

    Default

    Hi,

    you migth find the wiki helpful.
    http://wiki.untangle.com/index.php/Enable_SSH

  3. #3
    Untangler
    Join Date
    Jun 2008
    Posts
    50

    Default

    That helped with the "do_not_start.." problem. But, when I try to connect from my other computer, I still get a "Connection Refused" error. Is there some sort of security or settings I need to change before this will work?

    Jesse

  4. #4
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,049

    Default

    Normaly the internal network can access SSH without any truble.
    In your first post you typed
    I have searched on this forum and found a few things, but the answers were obviously given by and to people who know Linux pretty well. One tip I did see that I liked was changing the Listen Address to that of the gateway for my network
    Can you reset the settings?

  5. #5
    Untangler
    Join Date
    Jun 2008
    Posts
    50

    Default

    That was it. I'm able to connect using SSH now. However, I have one question. The change I was attempting to make was one to allow only computers from inside my network to connect to the Untangle box. Here's what I did:

    * vi /etc/ssh/sshd_config
    * add a line: ListenAddress 192.168.1.1
    * save the file.
    * restart ssh: /etc/init.d/ssh restart

    what I did to fix it and make it work again was to comment out the "ListenAddress" line. Is there some other way to do this so I make sure my connection is secure?

    Thanks,
    Jesse

  6. #6
    Master Untangler
    Join Date
    Oct 2008
    Posts
    913

    Default

    that only changes the listening address, not necessarily who can get to it.

    on my debian and arch servers i modify /etc/hosts.allow and change the line:
    sshd: ALL
    to
    sshd: 1.1.1.0/255.255.255.0

    just substitute that with your local subnet

  7. #7
    Untangler
    Join Date
    Jun 2008
    Posts
    50

    Default

    There was no sshd: line in that file, so I added it. My network uses the format 192.168.1.x, so, should the line be:
    sshd: 192.168.1.0/255.255.255.0 ?

    Will this allow all computers on the network to access the ssh service?
    Should I have to re-boot the box after this change? I hooked back into SSH after this change, and it let me in, but I don't want that to change after a re-boot.

    Thanks,
    Jesse

  8. #8
    Master Untangler
    Join Date
    Oct 2008
    Posts
    913

    Default

    you shouldnt have to reboot for it to take effect

    was there a line?
    all: ALL

  9. #9
    Untangler
    Join Date
    Jun 2008
    Posts
    50

    Default

    No, there are several lines of comment at the top, and a couple examples that talk about "all:", but there were no lines other than that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2