Results 1 to 8 of 8
  1. #1
    Untangler
    Join Date
    Jan 2008
    Posts
    35

    Default Virtual UT in bridged mode

    Hi!

    I ran into some issues when trying to install (from bare metal) a UT as a virtual machine. All settings is copied from a "live" working machine.
    It is set-up as a bridge, and in that mode the ext interface refuse to communicate.
    If I change it to a router everything communicates fine.

    The virtual NICs are connected to separated port groups in VMware, and connected to different VLANs outside VMware.
    I guess this has something to do with how VMware handles the bridge mac adress.

    Please response about tips how to dig further and solve the problem , or if you have seen similar problems.

    /Ake

  2. #2
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,042

    Default

    Hi Noctiluca,
    Can you post some screen shots of the setup.
    Specially the VMware Host Edit screen and VMNetwork setup.

    How many nics dose the Hardware have? (the real hardware server/client)

  3. #3
    Untangle Ninja dbunyard's Avatar
    Join Date
    Nov 2008
    Location
    Westerville, Ohio, USA
    Posts
    1,051

    Default

    Make sure you have promiscuous mode enabled on the properties of the virtual switches that Untangle is using.
    Dan

    You may one day find something interesting here. Today is not that day. Tomorrow isn't looking too good either.

  4. #4
    Untangler
    Join Date
    Jan 2008
    Posts
    35

    Default

    Thanks for the quick replies.
    I will send som screenshot within 12 hours.

  5. #5
    Untangle Ninja dbunyard's Avatar
    Join Date
    Nov 2008
    Location
    Westerville, Ohio, USA
    Posts
    1,051

    Default

    Did you check if promiscuous mode was accepted on the Virtual Switches that Untangle is using? Here is a screen shot of where to check.
    Dan

    You may one day find something interesting here. Today is not that day. Tomorrow isn't looking too good either.

  6. #6
    Untangler
    Join Date
    Jan 2008
    Posts
    35

    Default VMWare switch settings

    Hi.
    Some more information:
    As you have mentioned, I guess we have some miscofiguration in our virtual switch? I am a little anxious to do something wrong here, so maybe the best would be to create a dedicated switch for UT?
    It is an ESX installation with a redundant cisco switch network outside.
    Screenshots of the vmware switch settings are attached.

  7. #7
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,042

    Default

    The Virtual Switches need to accept Promiscuous mode.
    From your screenshots they are configured to reject.

    Hit Properties... on the Virtual switch.
    Then Mark the "vSwitch 56 ports" and hit Edit.
    Go to the "Security" tab and change Reject to Accept for the "Promiscuous mode"

    To the same for all Virtual Switches that UT is connected to.


    Do both Virtual Switches connect to the same Cisco Switch?

  8. #8
    Untangler
    Join Date
    Jan 2008
    Posts
    35

    Default Still confused

    Attached more recent screenshots of the vmware settings.
    Double-checked all settings in UT and vmware. Checked the network, VLANS, adress, ping...
    Everything is configured exactly the same in virtual and "real world" UT.
    Could the change between the bridges cause confusion of where to send the packets? Does the ARP table has to be tampered?
    Maybe this configuration not is allowed together with a single virtual switch?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2