Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2009

    Default Untangle in bridge mode

    I'm having some major issues trying to get bridge mode working.

    I have some added complexity because I am running untangle in a hyper-v virtual machine with virtual networks.

    From what I can tell, there are no problems with using the hyper-v legacy network cards. They appears to be on-line and I can communicate over the internet with the untangle box. The only fault I find is that the legacy network adapter's driver has a link state problem and so the two adapters always show disconnected and unknown in the network settings of untangle. This could be related, but I don't know enough to be able to tell.

    I think I am just missing something simple. There unfortunately is no documentation that adequately describes how bridging works and how it should be setup.

    Here's what I've got virtually speaking:

    WAN -> vswitch -> eth0-Untangle-eth1 -> vswitch -> Server

    Where 'vswitch' is a virtual switch. (There are two virtual switches)

    Untangle eth0 is configured as WAN, with one of my available public IP addresses. Lets call it Gateway would be

    Untangle eth1 is set to bridged with external/wan.

    My server is configured to a second public IP address. Lets say it is Same gateway

    For some reason I cannot get any communication between the untangle box and the server, nor from the server to the internet.

    In all the diagnostics I have done, it appears they are just completely unable to communicate. However, I have seen an arp entry show up on the untangle box with the IP and MAC address of my server when I try to ping the server. Its not consistent, but I did see this once, and so I figure there has to be partial functionality there and I am just missing something pretty obvious. However, monitoring TCPDUMP hasn't shown any traffic on the server at all, and from what I can tell I cannot find any associated traffic on the untangle box.

    If I switch the server directly to my WAN port it works fine. So no configuration issues there.

    Please help.

  2. #2
    Untangle Ninja
    Join Date
    Jan 2011


    When installing Untangle on VMWare, you have to configure the network adapters to 'Promiscuous Mode: Accept' (on the host itself, not in the individual VM), else at the very least bridging won't work.

    Something similar is probably necessary for Hyper-V.
    Last edited by johnsonx42; 03-20-2011 at 10:10 AM.

  3. #3
    Master Untangler
    Join Date
    Dec 2009
    Olympia, WA


    In hyper-v server r2/server 2008 r2+Hyper-v you need to check the allow mac spoofing checkbox for each of untangles legacy network cards, you can't see this checkbox from vista or server 2008, has to be 7 or r2.

    Otherwise Untangle can see the internet, but boxes behind can't.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

SEO by vBSEO 3.6.0 PL2