Results 1 to 10 of 10
  1. #1
    Untangler
    Join Date
    Mar 2008
    Posts
    86

    Default Auto-upgrade frozen

    Sorry for hijacking Angelknight's thread - if one of the mods wants to move my posts over here to this thread, feel free.

    My UT box autoupgraded sometime >24hrs ago. About 24hrs ago, I went to login to the web interface of my UT box to add a port forward, and found there was an upgrade in progress. After reading on the forums here that it took people about 5 mins to complete, I thought it strange there was no progress in 10 mins.

    It has been stuck on:
    http://dl.dropbox.com/u/9818705/Untangle-update.PNG

    For 24 hours now. Top hasn't changed much except mongrel_rails has a bit more time under its belt...
    http://dl.dropbox.com/u/9818705/UT%20-%20top2.PNG

    I saw a recommendation in another thread to use the recovery utilities... I haven't touched anything (except to run top and uptime) but I need to be able to get into my UT box to add that port forward.

  2. #2
    Untangler
    Join Date
    Mar 2008
    Posts
    86

    Default

    Unless, of course, it's time to just scrap the entire install, download a current version ISO and install from scratch. I think I can almost remember all my settings now...

  3. #3
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    paste the output of 'ps aux' and 'pstree'
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  4. #4

  5. #5
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    Doesn't look like its running.

    I would try 'apt-get --yes dist-upgrade' and answer yes to any questions.
    It may require an 'apt-get -f install' to resume
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  6. #6
    Untangler
    Join Date
    Mar 2008
    Posts
    86

    Default

    or a dpkg --configure -a which is what apt-get told me to do.

    it's currently running the cc -c's that showed up on the weblogin page.

  7. #7
    Untangler
    Join Date
    Mar 2008
    Posts
    86

    Default

    Then after that finished, I ran 'apt-get --yes dist-upgrade'

    I'm guessing after now manually running the update to 9.0.1, I should reboot?
    Last edited by Spunner; 07-06-2011 at 09:55 PM.

  8. #8
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    Yes I would reboot if it is finished.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  9. #9
    Untangler
    Join Date
    Mar 2008
    Posts
    86

    Default

    Roger. You can mark this thread SOLVED if you like.

  10. #10
    Master Untangler
    Join Date
    Dec 2009
    Location
    Olympia, WA
    Posts
    113

    Default

    Ok, there is the missing command I needed, my 9.0.0 upgrade has finally completed.
    Installing 9.0.1.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2