Results 1 to 7 of 7
  1. #1
    Newbie
    Join Date
    Jul 2011
    Location
    Portland, OR
    Posts
    7

    Default Performance Issues with v 9.x

    Similar Issue to:
    "untangle 9 gettting probelem"
    forums.untangle.com/installation/25497-untangle-9-gettting-probelem.html

    I currently have a Frontier FIOS connection with 25Mbps connection (both ways). I have been having an issue with my UTv9.00 (upgraded to 9.01) in which my download speeds have only been 1.5Mbps. Yet upload would allow me to go to 15Mbps (as measured by www towerstream com / Speed aspx, using their Seattle server).

    This weekend I bypassed the UT box and consistently got 25Mbps each way (as measured by www towerstream com / Speed aspx, using their Seattle server). The first thing I did was guess that there might be a config issue with my UT box. So I wiped it and did a clean install of 9.0.2x32. This produced a whopping 1Mbps download and 10Mpbs upload connections. (Not what I was looking for).

    I then wiped it clean and installed UT v8.1.1x32 and I now get 25Mbps connections both ways. I also setup UT NOT to auto update as I do NOT want 9.x on it due to it having this nasty issue with slowing down my connection speeds.


    My issue is, now I can not download any of the apps (like the firewall). I get a message saying I HAVE to upgrade to 9 in order to install the application. So, I upgrade to 9 and get the firewall at 1.5Mbps or stay on 8 with no firewall and get 25Mbps. Is there any way to still get the version 8 Lite apps?

    Thanks,
    Rhett

    Shuttle
    AMD Phenom II x4 910e (2.6GHz)
    4GB Ram
    500GB HDD (smallest and cheapest at time of purchase)
    1x Intel 100/1000 Dual-Port Server NIC (WAN and Internal)
    1x Intel 100/1000 Server NIC (DMZ)
    All Default installations on UT software

  2. #2
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,162

    Default

    Going back a version isn't a supported solution. 9.0 didn't cause the speed changes, however it did bring in some changes that do break speed tests. Just because speedtest.net says it's slow doesn't mean it actually is.

    You need to troubleshoot the issue, not plaster over it with a reload.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  3. #3
    Newbie
    Join Date
    Jul 2011
    Location
    Portland, OR
    Posts
    7

    Default

    Needing to troubleshoot is correct. However, getting my system working was much more important. I used the speed tests as another tool to help to confirm what I was seeing, not the basis of my diagnosis. When it constantly take 30 minutes (or more) to download Firefox updates (with all applications Lite applications within UT disabled, QoS disabled, etc) then there is an issue. When attempting to download a 100MB file, via FTP, says it will take 24 hours (and then proceeds to act accordingly) there is an issue. (Two of many examples of this issue.)

    The plaster over it did two things. It gave me a clean install so that I know see if my configuration was an issue. It is not. It also got it up and working, which is usually a good thing to have. Now, I get to show my @ss and say I need help. I am good with Windows, but only know that there is thing other OS call Linux. Would all of you Linux gurus be able to assist a Linux nob in using any(all) commands to help troubleshoot this? (I do not even know how to read the log files in linux, and this would be a great skill to have. I know they exist as I have seen people mention them in other form posts.)

  4. #4
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,162

    Default

    Well the changes in 9.0 heavily impact the Intrusion Prevention module, namely, it actually works now. I'd turn that off just because at this point.

    Beyond that, read your attack blocker logs. Anything with a reputation over 100 needs investigated.

    Finally, just to verify your platform is good. Run this command on the terminal

    /etc/init.d/untangle-vm stop

    Then run your speed tests. That command kills the UVM, essentially reverting Untangle to a NAT router. If you've still got performance issues with the UVM stopped, your hardware has something going wrong with it. Troubleshooting that, is going to be... difficult on the forums.

    /etc/init.d/untangle-vm start to start the UVM back up again.

    Look into the contents of /var/log/uvm, specifically if you see any .crash files.

    cat will output text files to the screen. tail does the same but only the -number of lines, etc tail -10 will show the last 10 lines of a file.

    nano to edit files, but be careful if you do that.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  5. #5
    Master Untangler
    Join Date
    Mar 2011
    Location
    Auburn, NY
    Posts
    438

    Default

    Worth looking at your interfaces for errors also.

  6. #6
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,162

    Default

    Quote Originally Posted by AdamB View Post
    Worth looking at your interfaces for errors also.
    That isn't a bad idea, the command is ifconfig.

    P.S. I'm doped up on allergy/cold meds... so take what I say with a grain of salt today. My brain isn't entirely functional. Of course there are those around here that would probably say the same thing when I am fully functional.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  7. #7
    Newbie
    Join Date
    Jul 2011
    Location
    Portland, OR
    Posts
    7

    Default

    Thank you (all) for your assistance. I will take a leap of faith and redo the UT to version 9.x. At this point it may have to wait until this weekend, when I can dedicate more time to it. I will let y'all know what I find.
    Rhett

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2