Results 1 to 10 of 10
  1. #1
    Untanglit
    Join Date
    Sep 2008
    Posts
    17

    Default Package installs are failing with a jsonrpc error following upgrade to 9.3

    Hi

    I upgraded my untangle install to 9.3 from 9.2.1 today and everything appears to have gone smoothly except for the spamblocker package failing to be installed after the upgrade and the ability to install it or any other package that wasn't already installed being broken. What I get when I try and install a package now is the following warning popping up:

    An exception has occurred:

    java.lang.NoClassDefFoundError
    com/untangle/uvm/vnet/AbstractNode

    Error: at http://172.16.80.254/jsonrpc/jsonrpc...6109594:461:37

    and then the package just flashes "loading app" for awhile and then stops. I have a support license with Untangle and have asked for help but no feedback as yet so hoping someone here might have some ideas so I can stop the spam that has been flooding in all day.

    Thank you

  2. #2
    Untanglit
    Join Date
    Nov 2009
    Posts
    24

    Default

    I'm in no way an Untangle expert...But when I did a clean install last I had modules hanging on installing and strange errors.

    I tried using Internet Explorer instead of Firefox and all the modules installed straight away with no errors.

    It's worth a try maybe while support get back to you.

  3. #3
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    Quote Originally Posted by habbers View Post
    An exception has occurred:

    java.lang.NoClassDefFoundError
    com/untangle/uvm/vnet/AbstractNode
    If you are receiving this error, it is likely that you are only half-upgraded and that the upgrade has been interrupted. I would contact support with the tab on the right hand side and they can assist you.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  4. #4
    Untanglit
    Join Date
    Sep 2008
    Posts
    17

    Default

    Thanks for your replies. I tried IE but response was the same. My support request has been assigned so hopefully will get a response soon.

  5. #5
    Newbie
    Join Date
    Apr 2012
    Posts
    7

    Default

    My Untangle upgraded itself last night and now I have the same problem. WTF, it was fine, now it's broke. I thought MS only did broken upgrades...

  6. #6
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Lake Tahoe
    Posts
    9,655

    Default

    Call support. They can help debug and correct any problem they find. ...Unlike MS.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  7. #7
    Untangler
    Join Date
    Sep 2011
    Posts
    76

    Default

    Same here. It cannot be coincidence and I don't think we have all had a half-upgrade.

  8. #8
    Master Untangler
    Join Date
    May 2010
    Posts
    105

    Default

    yep... me too after upgrading to 9.3. Spam blocker got de-installed and cannot be installed because i get the same error.

  9. #9
    Untangle Ninja mrunkel's Avatar
    Join Date
    Jul 2008
    Posts
    3,022

    Default

    Contact support, we will get it straightened out. Your systems are blocked on upgrade 'cause you installed a patch you didn't need. Just open a ticket with your UID and we'll get it working. -----> over there is the support button.
    m.
    <BR>
    Big Frickin Disclaimer:
    While I'm pretty sure, I can't guarantee that I know what I'm doing. There might be a better way to do this, and this way might actually suck. Make sure you understand the implications of what you're doing before trying to follow these directions.
    <BR>It often helps troubleshooting if you have a good network map. Look <A HREF="http://forums.untangle.com/tip-day/5407-how-draw-network-diagram.html">here</A> if you want my advice on how to draw one. <BR> <B>Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com<B>

  10. #10
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    Yeah, contact us. easy fix. We have to remove some 9.2 logic that is still present on your system from a patch.

    Sorry about that. The problematic patch was the 9.2 spam blocker event log. It was fixed in a super early build of 9.2 but we put it on the wiki for those users. I probably shouldn't have because there were probably only one or two.

    I didn't realize some people just like to run all patches. I would discourage you from doing this unless actually effected by the issue, and in the future I'll add more version checking to be safe.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2