Page 1 of 3 123 LastLast
Results 1 to 10 of 29
  1. #1
    Newbie
    Join Date
    Nov 2009
    Posts
    4

    Default Untangle Delays in Emails being sent outbound

    I'm having an issue that seems to be odd. I cannot send emails without delays
    I had 9x installed on an untangle box and had no issues at all with it. I have exchange 2010 on the inside of my network and was having no issues with sending emails outside of our network.
    I installed 10.1 and within 10 hours I was getting delays in sending emails outside of the network. I unplugged the untangle box and voila everything sent. Along with this it strips off attachments, as outside recipients are not getting attachments when the email arrives. I removed the untangle box and installed a new(er) PC even though the status during installation said that the processor was Great and Memory was Great on the original 10.1 box.I decided maybe the issue was that box. After installing the second box ( i5 box with 4 GB of memory). Within 10 hours I was in the same boat.
    The current setup of the untangle is identical to the 9x box, Bridged mode and attaching directly to my firewall. I am not scanning outgoing emails within the configuration I have spam filter light, Antivirus light, Phish blocker and reports. I have webfilter light and Application control light turned off but installed
    Any help would greatly be appreciated.

  2. #2
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,510

    Default

    I assume you have a mail server on site?

    Untangle Spam Filtration is HEAVY. And, you should be aware that it does indeed scan outgoing e-mail, it just auto whitelists it. I've always found better performance to be had by creating a bypass rule for traffic sourced from the mail server, and destined to TCP 25.

    If you don't have a mail server on site, just don't install the spam blocker, it's not doing you any good anyway.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  3. #3
    Untangler
    Join Date
    Aug 2011
    Posts
    35

    Default

    I had the same issue with one site that sending and recieving email was taking long time for some domains, not for all, 2 to 3 days and once I removed untangle it was very quick. It must be a known issue to Untangle or any settings. They have sbs2011 with exchange 2010 onsite.

  4. #4
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,049

    Default

    First thing first this thread seams to be started with a issue of outgoing and not incoming so all issues with incoming is another issue. (Start your own thread)

    As Sky-knight say by default the Spam module will whitelists all outgoing emails so it should not capture any emails.
    But that seams not to be the issue. (All mails is delivered just with a delay)

    This will probably have to do that the spam module will "pause/break" smtp sessions if the CPU load is "high" or what you have configured it to be.

    So adding the Bypass rule that Sky suggest is a wonderful idea and will "correct" that behavior.



  5. #5
    Untangler
    Join Date
    Aug 2011
    Posts
    35

    Default

    how do you do that?

  6. #6
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    You click on whatever forum ("Networking") and click the "Post New Thread" button at the top.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  7. #7
    Newbie
    Join Date
    Nov 2009
    Posts
    4

    Default

    Quote Originally Posted by sky-knight View Post
    I assume you have a mail server on site?

    Untangle Spam Filtration is HEAVY. And, you should be aware that it does indeed scan outgoing e-mail, it just auto whitelists it. I've always found better performance to be had by creating a bypass rule for traffic sourced from the mail server, and destined to TCP 25.

    If you don't have a mail server on site, just don't install the spam blocker, it's not doing you any good anyway.
    OK I'm back with the same issue, I reverted back to 9 and didn't have this issue anymore but now have another 10 box up online and I'm again getting delays.
    How do you create a bypass rule for the email server?

  8. #8
    Newbie
    Join Date
    Nov 2009
    Posts
    4

    Default

    Ok I did find the bypass and put in source address is (exchange server ip) action bypass and enabled the rule
    Hope this fixes my issues. It doesn't happen to all emails just sporadically.
    Thanks everyone for your help! I'll let you know if this fixes the issue

  9. #9
    Untangler
    Join Date
    Sep 2008
    Posts
    82

    Default

    The problems that the OP described where the same problems I experienced when moving to v10 (I can't remember if it was v10 or v10.1). I have 2 separate offices each running Exchange 2003 that had been running for years with Untangle with no problems whatsoever with outgoing email but when both Untangle's moved to v10 there were problems with some emails being stuck in the outgoing Exchange queues.

    I just created a bypass rule for outgoing SMTP. Not what I wanted to do but don't have the time look into it further.

  10. #10
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,510

    Default

    If you had an old Untangle installation from 8.x or prior that was upgraded, you had a no rack policy for outgoing SMTP that was effectively bypassing the traffic. Creating the bypass rule simply puts that old idea back into the system.

    However, if you're slowing down sending queues, you don't have enough hardware for your Untangle. Spam Blocker requires a significant hardware investment, it's the most expensive module to operate.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2