Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Newbie
    Join Date
    Jul 2019
    Posts
    3

    Question Untangle 15.0 won't update to 15.1

    Hey folks,

    Just checked in the Untangle world and there is an update which was not automatically applied. I'm at 15.0 right now:
    Build: 15.0.0.20200319T120445.4755a056cd-1stretch
    Kernel: 4.9.0-11-untangle-amd64

    And 15.1 is out - does Untagle automatically update decimal point versions or I need to install the ISO all over? Yes, am still new to Untangle

    Many thanks!

  2. #2
    Untangle Ninja
    Join Date
    May 2008
    Posts
    1,335

    Default

    Updates are rolled out over time. Read this.
    https://forums.untangle.com/announce...available.html

  3. #3
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    9,210

    Default

    Quote Originally Posted by JPHebert View Post

    And 15.1 is out - does Untagle automatically update decimal point versions or I need to install the ISO all over? Yes, am still new to Untangle
    From 15.1 announcements:

    Quote Originally Posted by jcoffin View Post
    When will the upgrade be available for me?
    Upgrades are rolled out over time to the existing servers. If you want the upgrade immediately, email your box UID to support and request adding your UID to the Early Upgrade List.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  4. #4
    Newbie
    Join Date
    Jul 2019
    Posts
    3

    Default

    Many thanks!

  5. #5
    Newbie
    Join Date
    Nov 2011
    Posts
    6

    Default

    Quote Originally Posted by JPHebert View Post
    Many thanks!
    I have the 15.1 upgrade queued up, but when I try to upgrade I get "downloading upgrades failed"

    I have plenty of space and dns is working and pinging 8.8.8.8 etc from troubleshooting, what else could be wrong? Any troubleshooting that I can do?

  6. #6
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    9,210

    Default

    As it states, the download of some of the packages failed. It can happen for many reason. I would just try again at a later time. You can check which package by reviewing /var/log/upgrade.log
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  7. #7
    Newbie
    Join Date
    Nov 2011
    Posts
    6

    Default

    Thanks, yes I can see that it states that, and that is why I am here. What is a good period of time to try again? I have tried twice in three days. Do you believe that its a back end issue that will resolve itself or is it another good reason to try again later?

    Do you think checking the log is one of the best ways to determine one of the many reasons that this could fail? What sort of things am I looking for?

    Really, I feel like I'm interrupting someone's day here asking for a little support. As you can see with my post count, I would not ask if I did not need to.

    edit: To top it off, no upgrade.log file in that area. Is this file created when you start to download the packages, or only when they are all downloaded and the process begins?

    Annotation 2020-07-16 125805.jpg
    Last edited by spinkick; 07-16-2020 at 10:01 AM.

  8. #8
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    25,304

    Default

    I recommend you disable automatic updates, and simply wait until you see it be available.

    You'll want a configuration backup BEFORE the upgrade, so you have an easy restoration process if something goes wrong.

    If you feel put off by your response, please understand every single upgrade this forum is flooded with people asking this question. Upgrades are staggered, you get them when you get them. If you want them now, you must open a ticket with Untangle support to be put on the early upgrade list. Alternately you can reinstall your platform and restore a backup from your current v15.0 installation.

    No one can tell you when your device will be authorized otherwise. This reality is what the linked post is explaining. You're asking for a personal explanation. So now you have it, and I'll copy / paste this post somewhere to keep it because I'm going to need it again. You aren't the first, and you won't be the last!

    There is no reason to be in a hurry to get to v15.1 either. The new feature came in v15.0. v15.1 is nothing but the risk of an automagic OS upgrade, which works most of the time... but when it blows up, it blows up hard. Which again is why I recommend you turn off upgrades, that way you'll see the admin alert. I wouldn't harp on it, just put it on your monthly checklist. As long as you make it into v15.1 before Thanksgiving or so you'll be fine.
    Last edited by sky-knight; 07-16-2020 at 09:49 AM.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  9. #9
    Newbie
    Join Date
    Nov 2011
    Posts
    6

    Default

    Rob,

    I'm not the person that has created the thread, but It looked like a good area to comment since its under the same topic which is "15.1 upgrade issues"

    First, my upgrades are not set to automatic. In the upgrade available, it says "upgrade available!" and when you click the button, it gives the -oh so obvious, why did you ask?- "Download upgrades failed".

    Of course my question is one of many. This is a support forum. Where else would you like people to go to get support? I've searched old threads and I thought it was meaningful enough to create a new topic.

    Again, the 15.1 upgrade is already available to my firewall, and I was simply asking why when I press the download button that there are errors. I also asked for good places to troubleshoot myself so support folks (whom I am sure are paid to do this kind of thing) might be able to give me some clues so I can go away and not bother them. This would save everyone time other than calling my paid support number.

    Just seems like a strange way to offer support is all. I'm in no hurry but yes, I was offput by a very terse and enigmatic response. Thanks for trying to help and jumping in, I hope I havent come off as unthankful to you, but sheesh, what a way to answer a customer. Not your fault and thanks for trying.

    Stay safe, I hear AZ is really popping off right now in regards to the outbreak. I have family out there.
    Last edited by spinkick; 07-16-2020 at 10:11 AM.

  10. #10
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    25,304

    Default

    I saw that thread, but I don't see it now...

    Unless it's here? I didn't have time the moment when I first glanced at it. The "Download Upgrades Failed" error is a specific thing. That happens when APT for some reason cannot get the upgrades from Untangle's repositories. The error you need should be located in /var/log/uvm/upgrade.log

    Failing that, opening a ticket with Untangle support is your best option. They'll look into even unlicensed units.

    So no, your situation is not the usual HEY WHERE'S MUH UPGRADE?!? Question. You have something broken that needs fixed. I don't think that's a repo problem, but it might be!
    spinkick likes this.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2