Results 1 to 7 of 7
  1. #1
    Master Untangler
    Join Date
    Dec 2008
    Posts
    126

    Default Failed...Upgrade in progress.

    When I go to Config -> Upgrade I get a pop-up that states Failed Upgrade in progress. I've tried apt-get autoclean and apt-get update, both commands I found in this post....

    http://forums.untangle.com/installat...update-ut.html

    But that didn't seem to help. Here is the output from those commands if that helps. I also attached a screen shot of the error. Does anyone know why this happens and how I can get rid of it?




    ~ # apt-get autoclean [root @ untangle]
    Reading Package Lists... Done
    Building Dependency Tree... Done
    ~ # apt-get update [root @ untangle]
    Hit http://updates.untangle.com stable/main Packages
    Hit http://updates.untangle.com stable/main Release
    Hit http://updates.untangle.com stable/premium Packages
    Hit http://updates.untangle.com stable/premium Release
    Hit http://updates.untangle.com stable/upstream Packages
    Hit http://updates.untangle.com stable/upstream Release
    Hit http://updates.untangle.com corvette-1/main Packages
    Hit http://updates.untangle.com corvette-1/main Release
    Hit http://updates.untangle.com corvette-1/premium Packages
    Hit http://updates.untangle.com corvette-1/premium Release
    Hit http://updates.untangle.com corvette-1/upstream Packages
    Hit http://updates.untangle.com corvette-1/upstream Release
    Get:1 USN list | Ubuntu gutsy-security/main Packages [176kB]
    Hit Index of / gutsy/main Packages
    Hit Index of / gutsy/main Release
    Hit Index of / gutsy/restricted Packages
    Hit Index of / gutsy/restricted Release
    Hit Index of / gutsy/main Sources
    Hit Index of / gutsy/main Release
    Hit Index of / gutsy/restricted Sources
    Hit Index of / gutsy/restricted Release
    Get:2 Index of / gutsy-updates/main Packages [384kB]
    Get:3 USN list | Ubuntu gutsy-security/main Release [102B]
    Get:4 USN list | Ubuntu gutsy-security/restricted Packages [5577B]
    Get:5 USN list | Ubuntu gutsy-security/restricted Release [108B]
    Get:6 USN list | Ubuntu gutsy-security/main Sources [32.8kB]
    Get:7 USN list | Ubuntu gutsy-security/main Release [104B]
    Get:8 USN list | Ubuntu gutsy-security/restricted Sources [848B]
    Get:9 USN list | Ubuntu gutsy-security/restricted Release [110B]
    Get:10 USN list | Ubuntu gutsy-security/universe Packages [119kB]
    Get:11 USN list | Ubuntu gutsy-security/universe Release [106B]
    Get:12 USN list | Ubuntu gutsy-security/universe Sources [15.8kB]
    Get:13 USN list | Ubuntu gutsy-security/universe Release [108B]
    Get:14 USN list | Ubuntu gutsy-security/multiverse Packages [7858B]
    Get:15 USN list | Ubuntu gutsy-security/multiverse Release [108B]
    Get:16 USN list | Ubuntu gutsy-security/multiverse Sources [1196B]
    Get:17 USN list | Ubuntu gutsy-security/multiverse Release [110B]
    Get:18 Index of / gutsy-updates/main Release [101B]
    Get:19 Index of / gutsy-updates/restricted Packages [5968B]
    Get:20 Index of / gutsy-updates/restricted Release [107B]
    Get:21 Index of / gutsy-updates/main Sources [105kB]
    Get:22 Index of / gutsy-updates/main Release [103B]
    Get:23 Index of / gutsy-updates/restricted Sources [848B]
    Get:24 Index of / gutsy-updates/restricted Release [109B]
    Hit Index of / gutsy/universe Packages
    Hit Index of / gutsy/universe Release
    Hit Index of / gutsy/universe Sources
    Hit Index of / gutsy/universe Release
    Get:25 Index of / gutsy-updates/universe Packages [154kB]
    Get:26 Index of / gutsy-updates/universe Release [105B]
    Get:27 Index of / gutsy-updates/universe Sources [23.2kB]
    Get:28 Index of / gutsy-updates/universe Release [107B]
    Hit Index of / gutsy/multiverse Packages
    Hit Index of / gutsy/multiverse Release
    Hit Index of / gutsy/multiverse Sources
    Hit Index of / gutsy/multiverse Release
    Get:29 Index of / gutsy-updates/multiverse Packages [13.5kB]
    Get:30 Index of / gutsy-updates/multiverse Release [107B]
    Get:31 Index of / gutsy-updates/multiverse Sources [2322B]
    Get:32 Index of / gutsy-updates/multiverse Release [109B]
    Fetched 1049kB in 3s (299kB/s)
    Reading Package Lists... Done

  2. #2
    Master Untangler
    Join Date
    Dec 2008
    Posts
    126

    Default

    Never mind, it seems to have worked.

  3. #3
    Master Untangler
    Join Date
    Dec 2008
    Posts
    126

    Default

    I'm having the same issue again. I was thinking about installing the Professional Package, and when I click on it within Untangle I just get a pop-up that tells me "Failed Upgrade in progress." Anyone have ideas on how I can fix this?

  4. #4
    Master Untangler
    Join Date
    Jan 2008
    Location
    Sydney Australia
    Posts
    98

    Default

    What's in your /etc/apt/source.list file. Have you add anything to it (looks like you may have)
    If so, try commenting out the extra lines, and retry the apt-get update (you might have to do a apt-get clean first, then retry)
    See if that helps.

  5. #5
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    i would reinstall using the ISO and transfer your subscription
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  6. #6
    Master Untangler
    Join Date
    Dec 2008
    Posts
    126

    Default

    Here is the contents of my source.list

    deb http://074a-9dce-bf89-5302-75a5cb6-1d22681-d7512a7-cd53021:untangle@updates$
    deb http://074a-9dce-bf89-5302-75a5cb6-1d22681-d7512a7-cd53021:untangle@updates$
    deb http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted
    deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted
    deb http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
    deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
    deb http://us.archive.ubuntu.com/ubuntu/ gutsy universe
    deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy universe
    deb http://us.archive.ubuntu.com/ubuntu/ gutsy-updates universe
    deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-updates universe
    deb http://us.archive.ubuntu.com/ubuntu/ gutsy multiverse
    deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy multiverse
    deb http://us.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
    deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
    deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
    deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
    deb http://security.ubuntu.com/ubuntu gutsy-security universe
    deb-src http://security.ubuntu.com/ubuntu gutsy-security universe


    I would rather not have to do a reinstall to fix this. Is there anyway to preserve my quarantine items if I have to reinstall?
    Last edited by ezhess; 04-02-2009 at 11:14 AM.

  7. #7
    Newbie
    Join Date
    Aug 2008
    Posts
    8

    Default

    Quote Originally Posted by Bumblebee View Post
    What's in your /etc/apt/source.list file. Have you add anything to it (looks like you may have)
    If so, try commenting out the extra lines, and retry the apt-get update (you might have to do a apt-get clean first, then retry)
    See if that helps.
    *-- Worked for me!!! I removed the additional lines, then did apt-get upgrade.. reboot. Life is good. Many Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2