Results 1 to 7 of 7
  1. #1
    Newbie
    Join Date
    Jun 2018
    Posts
    5

    Default Cannot install IPS

    Hi,

    I'm having a strange issue since the upgrade to 16.3.2.

    My IPS disappeared from my installed apps list. When I went to reinstall it, I get the error message:

    "Name: java.lang.Exception: Too many instances of intrusion-prevention in policy null. (490)
    Message: Too many instances of intrusion-prevention in policy null."

    When I go to terminal and use the command "ucli instances", I do not have IPS in the list.

    I thought maybe the upgrade went squirrely, so I fresh installed 16.3.2. No change, same problem.

    I've been using Untangle as a VM on my ESXi 6.7 server for a couple years. Never an issue till now. My IPS reporting stopped on June 18th on my command center. My license is the "NG Firewall Complete".

    Any ideas?

    I'm about to get some sleep, so I'll check the thread when I wake up. Stayed up late trying to fix this problem.

    Thanks,

    Jason

  2. #2
    Newbie
    Join Date
    Jun 2018
    Posts
    5

    Default

    I found another problem that is probably related. Threat prevention also will not install. The error is:

    Exception!
    Name: java.lang.reflect.InvocationTargetException (490)

    Exception!
    java.lang.reflect.InvocationTargetException at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java: undefined

    Those two seem to be the only ones affected. I can start a new thread in the Threat Prevention area if desired.

    Regards,

    Jason

  3. #3
    Newbie
    Join Date
    Jun 2018
    Posts
    5

    Default

    Did another fresh install with 16.3.2 using the OVA file.

    This time, I imported my settings over 1 at a time and rebooted. I ended up getting all my settings imported and had everything working. Looked away for a few minutes at another tab and when I looked back, IPS app had disappeared. Attempting to reinstall gives me the same error. This is driving me nuts. I have spent hours on this problem.

    Jason
    Last edited by techspec6; 07-09-2021 at 12:52 AM.

  4. #4
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,258

    Default

    Is the backup from a 16.3.2 version?

    If you jump in to the console and run "ucli instances"
    Do you there see "intrusion-prevention" in a "RUNNING" state?

  5. #5
    Untangler
    Join Date
    Aug 2019
    Posts
    54

    Default

    What version are you running? It appears they had some licensing issues that gave users access to apps they weren't entitled to.

    https://forums.untangle.com/virus-bl...tml#post252308

  6. #6
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    9,743

    Default

    Quote Originally Posted by sperman View Post
    What version are you running? It appears they had some licensing issues that gave users access to apps they weren't entitled to.
    ]
    IPS is a free app.
    sperman likes this.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  7. #7
    Newbie
    Join Date
    Jun 2018
    Posts
    5

    Default

    Hey guys,

    I finally gave up on fixing it myself and submitted a support ticket. One of the engineers fixed my issue quickly, overnight, while I slept. They did not give any information as to what the problem was.

    I've since made a snapshot of the VM in case it decides to disappear again. I'm guessing I found a rare bug that'll probably be patched next release. Just a guess.

    You guys can lock this thread and mark it resolved.

    Thanks!
    Jason

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2