Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Untanglit
    Join Date
    Aug 2016
    Posts
    22

    Default L2TP Client Login crashes Untangle

    Good Evening,

    I am having an issue wherein every time an L2TP client establishes a session the Untangle FW crashes / restarts. I found an older thread that appears to indicate others have reported something similar however, no response on the fix.

    https://forums.untangle.com/ipsec-vp...-firewall.html

    Specs:

    Server: Checkpoint T-120
    CPU Count: 2
    CPU Type: Intel(R) Atom(TM) CPU D525 @ 1.80GHz
    Architecture: amd64
    Memory: 4.13 GB
    Disk: 233.39 GB

    Build: 15.1.0.20200615T124608.a9d75cc95d-1buster
    Kernel: 4.19.0-8-untangle-amd64
    History: yes (5)
    Reboots: 10 (8)

    A few other links stated to look for a ".crash" file of which i did not see any of those via an ssh session.

    All that being said, I know I can use OpenVPN (it is set up for the time being) however, I would prefer to not have to manage another piece of software since the OS (Windows 10 and MacOS) have native L2TP clients that function very well - IMO.

    Any help the forum members can provide is sincerely appreciated. I am happy to attach any relevant information to assist.

    -MW

  2. #2
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,132

    Default

    mfwade,

    Do you have QoS enabled? (I am tracking another issue with kernel panic and hw reload that goes away if i disable QoS)
    That box also has LT2P users and we can recreate it with traffic over L2TP but not just connecting. (need to put load on it)

  3. #3
    Untanglit
    Join Date
    Aug 2016
    Posts
    22

    Default

    WebFool,

    Yes, I do have QoS enabled.

    Listing of all Apps installed in case it helps...

    Web Filter
    Bandwidth Control
    Application Control
    Firewall
    Ad Blocker

    Reports
    WAN Failover
    WAN Blocker
    IPsec VPN
    OpenVPN
    Tunnel VPN

    QoS Enabled
    UPnP Enabled (Secure Mode)

    Thanks for the response, hopefully we can figure this out.

    I will try disabling QoS later today and see if the problem persists.

    -MW

  4. #4
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,132

    Default

    Can you try disableing QoS and see if the problem goes away?

  5. #5
    Untanglit
    Join Date
    Aug 2016
    Posts
    22

    Default

    So, i just tried disabling and subsequently re-enabling the QoS setting. Interestingly enough I have been connected via L2TP for the past 28 minutes. Previously I would get connected and then the FW would crash / reboot...

    I am not sure this is a "good" test however, so far so good. I will continue to test over the next few days and will report back.

    Please note, I am a single user that connects several devices (different local user accounts), so not the same as yours and probably not a significant load. If you would like I can assist in helping you albeit from abroad - US.

    -MW

  6. #6
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,132

    Default

    mfwade,

    I have added this thread to the support/jira ticket I have for my devices.
    Lets hope that yours stay working now :-)

  7. #7
    Untanglit
    Join Date
    Nov 2019
    Posts
    19

    Default

    I had similar behaviour and opened a ticket, the fix (which isn't what you want to hear) was to switch to OpenVPN.

  8. #8
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,132

    Default

    ncksh,

    Makes me sad that you were given that response.
    Have you tried to turn off QoS and see if that make the issue go away for you?

  9. #9
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    24,945

    Default

    Yeah that's not acceptable... Untangle support doesn't get to tell you to stop using the paid product, and start using the free one. Yes, it's an option, but it's not an acceptable one due to the financial responsibilities Untangle entered into when they SOLD the IPSec module.

    I suggest you hit support again, this time tell them to actually do their jobs. They need reminding of that fact from time to time.

    If Untangle wants to shed the support burden of L2TP / IPSec, they need to stop selling the module. Especially since that was the reason they told us it had to be a premium module to begin with!
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  10. #10
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,132

    Default

    ncksh,

    Did you buy your license directly from Untangle or a reseller?
    Resellers tend to have direct contact to one and the same support tech so they have or at least have had a better way in to support.

    But sadly there seams to have been some changes to how Untangle handle and operates both good and bad.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2