Results 1 to 4 of 4
  1. #1
    Newbie hostdummy's Avatar
    Join Date
    Jul 2008
    Posts
    5

    Default Firewall: FTP ko

    Ciao a tutti,
    sono alla seconda installazione di Untangle, la 5.3 in particolare, e mi trovo di fronte a questo problema: attivando il FW riesco a far passare tutto, anche un gateway VoIP piuttosto ostico, ma non i client FTP, o meglio, aprendo la 21/tcp essi riescono ad ottenere quanto segue:

    Stato: Risoluzione dell'indirizzo IP in corso per ftp.apple.com
    Stato: Connessione a 17.254.0.15:21 in corso...
    Stato: Connessione stabilita, in attesa del messaggio di benvenuto...
    Risposta: 220 17.254.0.15 FTP server ready
    Comando: USER anonymous
    Risposta: 331 Anonymous login ok, send your complete email address as your password.
    Comando: PASS **************
    Risposta: 230 Anonymous access granted, restrictions apply.
    Comando: SYST
    Risposta: 215 UNIX Type: L8
    Comando: FEAT
    Risposta: 211-Features:
    Risposta: MDTM
    Risposta: REST STREAM
    Risposta: SIZE
    Risposta: 211 End
    Stato: Connesso
    Stato: Lettura elenco cartelle...
    Comando: PWD
    Risposta: 257 "/" is current directory.
    Comando: TYPE I
    Risposta: 200 Type set to I
    Comando: PASV
    Risposta: 227 Entering Passive Mode (17,254,0,15,245,72).
    Comando: LIST

    purtroppo l'azione si blocca inesorabilmente sul LIST Vs il server FTP; ho settato tutti i clients, sia quelli Mac che Win in PAS Mode ma zero, questi sono gli interventi lato UT53 invece:

    - forwarding di tutto il traffico da WAN sulla 21 verso un client in LAN
    - disabilitato anti-virus su FTP
    - disabilitati alcuni controlli su FTP del modulo Intrusion Prevention
    - disabilitati alcuni controlli su porte dinamiche del modulo Protocol Control
    - disabilitato in File Transfer Override l'enable processing

    risultato ZER0 NEGATIVO... l'FTP dalla LAN (internal) funziona solo se disabilito il modulo Firewall.

    Idee?
    HD

  2. #2
    Newbie hostdummy's Avatar
    Join Date
    Jul 2008
    Posts
    5

    Default

    il thread prosegue qui, la soluzione è nei post successivi

    http://forums.untangle.com/showthread.php?t=4227

  3. #3
    Newbie
    Join Date
    Mar 2009
    Posts
    8

    Thumbs up

    Ciao. anche io ho avuto la necessità di configurare il port forward per FTP.

    Ho fatto Config Networking -> Port Forward e da lì ho abilitato "Forward TCP Traffic to...." e ho configurato l'indirizzo del pc che ospita il servizio e la porta 21.Abbastanza immediata come cosa.

    Per essere ancora più sicuro,avevo messo il blocco del traffico TCP sul Firewall,così punto punto vedevo come arrivava il segnale.Quando ho visto che arrivavo fino a lì,ho tolto il blocco e sono passato.

  4. #4
    Newbie
    Join Date
    Mar 2009
    Posts
    8

    Default

    Quote Originally Posted by andrea.ferraiuolo View Post
    Ciao. anche io ho avuto la necessità di configurare il port forward per FTP.

    Ho fatto Config Networking -> Port Forward e da lì ho abilitato "Forward TCP Traffic to...." e ho configurato l'indirizzo del pc che ospita il servizio e la porta 21.Abbastanza immediata come cosa.

    Per essere ancora più sicuro,avevo messo il blocco del traffico TCP sul Firewall,così punto punto vedevo come arrivava il segnale.Quando ho visto che arrivavo fino a lì,ho tolto il blocco e sono passato.
    In merito a questo commento,volevo segnalarvi che con la modalità di PortForward sopra descritta,nel caso si avesse la necessità di installare un Server FTP questo funzionerà al client solo in active mode.
    Nell'active mode il server tiene aperta la porta 21 sia per gestire le connessioni che per il trasferimento dei pacchetti.Purtroppo,la modalità predefinita nei client è quella passiva,ovvero il client tiene sempre aperta la stessa porta,ed è il server a cambiarla per gestire su diversi canali le diverse richieste (i server in passive mode vengono considerati meno sicuri,ma molto più compatibili e veloci).

    Per cui,se volete far funzionare il vostro server FTP "dietro" Untangle,dovrete configurare la regola di PortForward sopra descritta senza specificare la porta 21,lasciando il campo "New port(optional)" vuoto,in modo che sia il vostro server poi a decidere su quale porta instradare la chiamata.

    Spero di essere stato d'aiuto.
    Saluti

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2