Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Untanglit
    Join Date
    Apr 2012
    Posts
    15

    Default Network Balancing based on IP Range

    Anyone know if there is a way to setup network balancing to actually be more of a usage based on IP range? I set the following up
    Servers - 10.0.0.1 -> 10.0.0.69
    Desktops - 10.0.0.70 -> 10.0.0.254

    I have two wan connections configured on my untangle box and can use it to set it as a failover if the first goes down. But instead i would like servers to use WAN1 with WAN2 as backup, then have Desktops use WAN2 with WAN1 as a backup.

    Is this type of policy possible?

  2. #2
    Untangle Ninja
    Join Date
    Jan 2011
    Posts
    1,327

    Default

    that's exactly what WAN Balancer does: http://wiki.untangle.com/index.php/W...Source_Routing

    if you have Failover configured (and you should), then if either WAN fails it overrides the source routing and routes all traffic to the remaining interface.
    Last edited by johnsonx42; 04-14-2012 at 06:29 PM.

  3. #3
    Untanglit
    Join Date
    Apr 2012
    Posts
    15

    Default

    Well I was able to configure this but it doesn't seem to work. When I check what my IP is, it still displays the WAN1 interface when it should be WAN2 (i even ran tests). It does list External for WAN1 and DMZ for Wan2 - should it still work?
    --- Edit
    I Noticed this:
    There are three network configuration steps necessary to set up Multi-WAN. In the following example, we will convert the DMZ interface to a second WAN interface. A printscreen is provided for each. You can click on each printscreen to see a full-size graphic if needed.

    That seems to be my issue!
    Last edited by Centixo; 04-16-2012 at 02:07 PM. Reason: I'm an idiot

  4. #4
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    Quote Originally Posted by Centixo View Post
    Well I was able to configure this but it doesn't seem to work. When I check what my IP is, it still displays the WAN1 interface when it should be WAN2 (i even ran tests). It does list External for WAN1 and DMZ for Wan2 - should it stillw ork anyway?
    Routes are cached in WAN Balancer. If you just added a rule to put it on another WAN it won't take effect until the cache expires or you reboot.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  5. #5
    Untanglit
    Join Date
    Apr 2012
    Posts
    15

    Default

    Spoke too soon. I will try to reboot and see how it works. Thanks

  6. #6
    Untangler
    Join Date
    Dec 2010
    Posts
    83

    Default

    Hi,
    Both clients/ Servers and Desktops are in the same subnet. Use WAN Balancer to configure both WAN links and configure Traffic Allocation based on the WAN Balancer Input

    This will make sure, traffic from subnet 10.10.8.0 go via ISP-1 and 10.10.9.0 to go via ISP-2.

    Hope it helps.

  7. #7
    Untanglit
    Join Date
    Apr 2012
    Posts
    15

    Default

    I can't seem to connect to my second WAN at all which is very strange. I think this is the obvious cause to my issue. I tried to disconnect WAN2, shut it off, plugged it into my laptop, configured my NIC with the same settings and it works great once I turn it on. All traffic goes through.

    I disconnect it and hook it back up to the Untangle server it connects and the ping tests succeed. However, no traffic goes out of the cable modem. I tried to set it 0% WAN1 and 100% wan 2 as a test - the WAN1 seems to be the only one that is used. I've tested this by cleared the web cache, restarting the firewall, restarting my workstation that is being used as the test.

    No matter what only WAN1 is used. I verified it by going online and checking sites like ' what is my ip - and it always displays the wan1 connection. Also, I have gone to speed tests and can't break 10mb. My wan 1 is 10-15mb and wan2 is 80-90mbit.

  8. #8
    Untangler
    Join Date
    Dec 2010
    Posts
    83

    Default

    Which version of Untangle are you using? I'm testing Untangle on a VM now, I have configured it with 2 WAN connections each from DMZ in the Edge Firewall and one Internal Interface. I configured WAN failover and WAN balancer, i made a policy to allow only one Subnet "The Internal Interface, always goes via ISP-1". I it works fine, but when turn the link off, I have to close the explorer and relaunch it again, otherwise webpage will not refresh. When I turn back the link and I check whatismyip.com, it stays on ISP-2 unless I reboot the Untangle and it will go back to ISP-1.

    Tests on both links to external sites works well, Untangle uses Local DNS Server which forwards the DNS to external sites. Clients are pointing to Untangle Internal Interface IP and to Local DNS Server same as Untangle.

    Did you configured the second WAN connection as DMZ? You should have eth0 as External, eth1 as Internal, eth2 as DMZ "WAN". Does the Second WAN Interface has an IP, of it's bridged to External?

    Configure and IP Address with Gateway and DNS and tracert the traffic using both Links, and see does it flows correctly.

    Thanks,
    Hussain

  9. #9
    Untanglit
    Join Date
    Apr 2012
    Posts
    15

    Default

    I am using the following version:
    Build: 9.2.1~svn20120328r31539release9.2-1lenny
    Kernel: 2.6.26-2-untangle-686

    Here is my DMZ connection which is WAN2. I have it configured as WAN:


    This is my Static IP from my cable provider and the DNS is opendns. I have set this exact IP config on my laptop as a test (and it was on my old watchguard firewall) and the connection works.

  10. #10
    Untangler
    Join Date
    Dec 2010
    Posts
    83

    Default

    Is it a VM or a Hardware box?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2