Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1
    Untangler
    Join Date
    Jun 2009
    Posts
    92

    Default OpenVPN working good except no "Windows" network browsing?

    Hey guys,

    Pretty noob question here and although I have searched for an answer myself, have found nothing that really relates.

    I just upgraded our system (fresh install of course) to Untangle 10, and re-did everything manually.

    OpenVPN is working good...unfortunately our work network is still 192.168.1.X, so I am testing from my home network which is 10.10.10.X so it works good with no conflicts.

    Now, after successfully connecting from my home, I can ping everything on the work network, including the server at 192.168.1.2 (Untangle itself is 192.168.1.1, which is also pingable).

    I can also RDP into any machine using the local static 192.168.1.X address...in short it is working good!

    Question is: it is expected or even intended for normal "Windows" style network browsing to not function? Just browsing the network only shows my local home network, and manually typing in the machine name of work PC's comes up empty handed.

    Is there anything that can be done in terms of configuration for this to work? Or is it normal and expected that this does NOT work?

    i could have sworn I had it working under Untangle 9.xx but I cannot for the life of me remember how, or if there was anything special that had to happen first...

    Sorry for noob question, appreciate any response!

  2. #2
    Master Untangler TirsoJRP's Avatar
    Join Date
    Oct 2010
    Posts
    480

    Default

    To use the machine name instead of IP you need to enable Push DNS.
    Computers need to be on the same broadcast domain for Windows style network browsing, it should work if you type the IP/hostname.
    Be aware that Windows shares are not meant to work over slow wan links.

  3. #3
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,546

    Default

    The network browser in Windows is the single buggiest mess of code ever devised by man. DNS isn't a requirement for it to function, a domain however is. If you don't have a domain, and the remote machine can't find it (usually DNS), then it will never connect to the domain's master browser, and never get a list. Then it tries to make one, which is done via broadcasts, and those don't transit routers (Untangle). So yeah, this doesn't work, never worked, won't ever work. Unless you've got a domain.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  4. #4
    Untangler
    Join Date
    Jun 2009
    Posts
    92

    Default

    Interesting stuff here!

    Our server is a "domain" server, in the sense that the workstations use it for login authentication via active directory. As far as our local network is concerned, it is a domain server...but not in the sense that it is serving anything up to outside of our network (not running web site or anything off of it).

    Oh yeah, and it is only SBS 2011 Essentials, so not a "full" server at that.

    I notice there are quite a few interesting options in OpenVPN settings...is it just a matter of somehow configuring a client OpenVPN system (my test system at home) to point to the office server's internal IP for DNS when connected through OpenVPN?

  5. #5
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,546

    Default

    SBS is a Microsoft DC. So if you export DNS and get name resolution working the network browser should start populating on the remote device. Assuming of course said remote device is a domain member. I will however also point out this is VERY UNRELIABLE. I always \\servername when I need something ALWAYS. The browser is cute, but I've never relied on it. If I need a permanent mechanism for a client, I'll either map a drive, or make a shortcut to the specific resource.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  6. #6
    Untangler
    Join Date
    Jun 2009
    Posts
    92

    Default

    Again, thanks for the reply sky-knight...

    To clarify, when i talk about this "browsing", i am only referring to my ability to \\servername. I realize the actual browsing is flaky and unreliable.

    But at least right now, when I \\servername, I get nothing. But if I \\192.168.1.2(server internal IP) it works fine...so that is why I am convinced that if I tweak the OpenVPN settings somehow in Untangle (it is default now, and I cannot for the life of me figure out what I need to do), then typing in \\servername will DNS properly over the VPN.

    Maybe I am asking an even easier and more stupid question that even you thought at first? Lol...I am sorry if it is a simple thing I am doing wrong...like exporting DNS properly somehow in OpenVPN settings...but after having read the available info on the wiki, and help pages, I still cannot figure out what I am doing wrong.

    Your further advice would be very appreciated!

  7. #7
    Untangler
    Join Date
    Jun 2009
    Posts
    92

    Default

    I should point out that my OpenVPN settings in Untangle are default...I guess what I am asking is:

    What configuration change should I make for this to work (being able to resolve \\servername from a client machine)?

    Currently, default settings for default group, which is all I have set up, are "push DNS"...then further down "push dns server" is set to "openvpn server". Is this wrong somehow? After reading the help page, I wonder if I need to use "Push DNS custom" and send the server internal IP, since the Untangle doesn't actually have the DNS lookups for our internal domain, I don't think...

  8. #8
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,546

    Default

    That's exactly what you need to do. Push an appropriate dns server so after the client connects to the VPN nslookup servername works.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  9. #9
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    Quote Originally Posted by jeremyf View Post
    Currently, default settings for default group, which is all I have set up, are "push DNS"...then further down "push dns server" is set to "openvpn server". Is this wrong somehow? After reading the help page, I wonder if I need to use "Push DNS custom" and send the server internal IP, since the Untangle doesn't actually have the DNS lookups for our internal domain, I don't think...
    Indeed if you want DNS lookups to go through your internal domain (and untangle doesn't point there) you'll need to push the IP of your internal server instead. If Untangle points to your internal server (and only your internal server) it will get forwarded there anyway.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  10. #10
    Untangler
    Join Date
    Jun 2009
    Posts
    92

    Default

    Alright! I can do that...

    Made this change to the 'default group' settings in OpenVPN settings within Untangle,:

    Push DNS custom is set to :192.168.1.2 (server internal IP)
    For good measure I also set the 'push DNS domain' to "local.ourlocaldomain.com"

    So far, still cannot resolve machine names...

    now do I need to re-create the executable install file for the client machine?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2