Results 1 to 10 of 10
  1. #1
    Newbie
    Join Date
    Aug 2010
    Posts
    5

    Default Broadcast Multicast through Bridge mode

    Could someone either tell me that what I am trying can or cannot be done and if it can please explain what I am missing to make it work.

    My current setup is ISP --> Router --> Untangle (bridge mode) --> switch --> computers

    I have an EOIP tunnel between my router and another and we are able to do multicast across our tunnel between networks. However when I put untangle in the mix it blocks or drops all the multicast traffic. My understanding was when untangle was set up as a bridge that these packets would pass though however this does not appear to be the case.

    For example my router can use winbox to connect. When untangle is not in the mix you can press the browse button and the router will show up in the list as it broadcasts UDP packets and you can see the MAC and connect. When untangle is in the mix it will not show up in the list. I can connect to it sill if I put in the IP but the broadcast doesn't show. Is there something in untangle I can do to allow these to pass through or can this simply not be done.

    Thanks,
    KJ

  2. #2
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    When you say "multicast" what do you mean? Traffic to what IP or IP range? 239.0.0.0/8?
    What version are you running?

    Thats not how Untangle bridges work.
    More information here:
    http://wiki.untangle.com/index.php/N...ation#Bridging
    http://wiki.untangle.com/index.php/N...2_really_means.

    It doesn't mean its not possible, but the first step would be to determine what version you are running.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Newbie
    Join Date
    Aug 2010
    Posts
    5

    Default

    Yes to your question regarding the IP range.
    Running version 10
    Build: 10.0.0~svn20131211r36618release10.0-1squeeze to be more specific.

    Thanks for the response.
    KJ

  4. #4
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    I would upgrade to v10.1 first. Multicast is routed differently in v10.1

    If its not available to your server yet. You can:
    1) wait a a few more days/weeks
    2) contact support
    3) add your server to the priority queue: http://forums.untangle.com/off-topic...e-request.html
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  5. #5
    Newbie
    Join Date
    Aug 2010
    Posts
    5

    Default

    Upgrade doesn't show up yet in the upgrade section. I will wait a few weeks until it comes out and then revisit this. Is there anything I will need to do or do you think this should work with the upgrade?

    KJ

  6. #6
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    I'm not sure since I don't know why it isn't working now....

    You'll need to upgrade then save settings in config > network so the new rules apply.
    Then test again.

    Probably debug with tcpdump...
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  7. #7
    Newbie
    Join Date
    Aug 2010
    Posts
    5

    Default

    Ok I have updated my untangle to the latest 10.1 version.

    I removed the bypass rule and routes and tested and it did not work.
    So I have added the following back in
    Network->Routes
    Network = 239.0.0.0
    Netmask = 8
    Next Hop = Local on External

    (do I need to ad one for Local on Internal too to allow communications both ways?)

    I also added the following ByPass rules
    Destination Address -- is -- 239.0.0.0/8
    Action = Bypass
    and I added
    Source Address -- is -- 239.0.0.0/8
    Action = Bypass

    Still multicast does not appear to pass though the untangle box.

    Any other ideas?

    Thanks
    KJ

  8. #8
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    Do you mind if I take a look in your server at the UID you PMed me?
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  9. #9
    Newbie
    Join Date
    Aug 2010
    Posts
    5

    Default

    Go ahead. PM me with anything you need me to do.

  10. #10
    Untanglit
    Join Date
    Jan 2014
    Posts
    17

    Default

    I've had a bit of trouble with multicasts and OSPF, but got that to work just fine (bypass 224.0.0.0/8). So technically, it should work, maybe you're not adding the multicast to the global bypass?

    My problem is once multicast hello packets are exchanged, the protocol goes into OSPF unicast mode for the DR/BDR negotiation, and this is where it dies. Tried adding rules for routers' source and destination address, but tcpdump shows that Untangle responds with ICMP time expired in transit, which is how iptables responds... So any suggestions are more than welcome!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2