Results 1 to 7 of 7
  1. #1
    Newbie
    Join Date
    Jun 2008
    Posts
    3

    Question Exchange 2007 with UT in Router mode

    I have installed 3 U.T. boxes this week 2 with Exchange 2003 and 1 with 2007. The 2003 works great and 2007 no go.

    What I have done.
    Checked DNS (tried local DNS server and External DNS server) tried both hways.
    I am able to ping my internal Exchange server. (192.168.10.10) which is also my DNS server.
    I can also ping the internal domain (mydomain.com) and it resolves the correct IP (which PublicIP port 25 is forward to 192.168.10.10 port 25)
    I can ping from the console terminal and telnet in on port 25
    I can open up the U.T. box send a test email to gmail.com, yahoo.com, etc and it works.
    Inbound and outbound email has been tested and is working.

    The box will not send to my internal Exchange 2007 server.

    I have also read article http://forums.untangle.com/showthrea...=exchange+2007
    Also, another article that had me add my U.T. box to a reciever connector on the exchange 2007 server and made sure it can take anym access, hope i did that correct (open relay)
    Also, read another article that said to make sure that I had port forward setup correctly with external and internal interfaces checked, protocol TCP, port 25 from my Public IP

    I have rebooted the U.T. box and from the terminal I run a mailq and I get about 50 messages that says something linke this:

    5h 1.4K 1K6Z03-00038a-VR <> *** frozen ***
    untangle@gold.local

    3h 1.3K 1K6b3d-0001VL-Um <> *** frozen ***
    root@Knoppix
    Last edited by ncalvert; 06-11-2008 at 08:35 PM.

  2. #2
    Master Untangler
    Join Date
    May 2008
    Location
    Orlando, FL
    Posts
    105

    Default

    Are you sure it's not the 2007's junk and spam filtering?

  3. #3
    Newbie
    Join Date
    Jun 2008
    Posts
    3

    Default

    I have disabled all of Exchnage 2007 spam features.

    I have resolved the issue by using a username and password under the email settings. You HAVE to enter the username in the following frmat domain.local\username

    username@domain.local does not work.

    Lets keep this open because the last reports that came down did not have the PDF attachments. So that might be a problem

  4. #4
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,542

    Default

    I think this has something to do with NAT reflection. The MX record should be resolving to the external IP of the UT server. In this case the UT sends to itself and the NAT rule has to forward it in. You might try adding a nat rule to specifically redirect anything that hits the internal interface on tcp 25 to the exchange server. I'm not sure which interface UT grabs to send that message but that interface will probably need some special attention to get sendmail to dump it over...

    Another thing you can do is disable UT's ability to send mail directly. Configure it to use the internal address of the exchange server with appropriate SMTP credentials and it should fire up.


    Also, the username@domain.local login has never worked for me with my domains. I've always had to use the domain\username syntax. Heck, this syntax is used exclusively by the windows login screen on Vista. Just try loging into a Vista box as the domain admin...
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  5. #5
    mdh
    mdh is offline
    Untangle Ninja mdh's Avatar
    Join Date
    Aug 2007
    Posts
    4,752

    Default

    ncalvert,

    If you don't have PDFs attached, forward the email to your Gmail account and you will likely find them there. That issue is talked about on the Untangle Reports forum. Its partly a Microsoft issue (in some cases, its ALL a Microsoft issue), and we have a bug against this as well so that we can construct the email headers in a different way to make it more compliant. It should work now, but in "some" cases, it doesn't.

  6. #6
    Untanglit
    Join Date
    Oct 2007
    Location
    Dallas TX
    Posts
    18

    Default

    I'm having a similar issue with an exchange 2007 server. I have outbound and mail traffic internally and to users outside the network however I have yet to successfuly receive email from outside the network.

    I've setup a port forward on the UT box to the exchange 2007 internal IP, added the UT box IP address to the receiving connector. I am at a loss and this is my first exchange 2007 configuration.

    MX record is resolving to public IP on UT box, but telnet on port 25 gets no answer. Exchange mailbox is authenticating with active directory on dc1.

    help

  7. #7
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,542

    Default

    Welcome to the forums...

    Double check that Exchange is actually listening on port 25. Exchange 2007 does NOT configure the internet smtp connector by default. All that is required on the current UT is a port forward on 25 to make Exchange work, then moving the admin port off 443 so you can forward 443 to the box to make Active Sync, OWA, and Entourage work. I just did this last week, Exchange 2007 was an interesting project to tackle, I haven't touched an Exchange server in almost 10 years. The server is happy, online, and UT is ripping the CRAP out of the spam hitting it. And yes, the server can get the digests...

    Last 24 hours?
    Scanned emails (SMTP) 18,419
    Spam connection rejected using DNSBLs 16,287 88.42%
    Spam & Quarantined 1,518 8.24%
    Clean & Passed 614 3.33%

    Thank you Untangle, this customer will be getting Pro just as soon as the paperwork clears their Finance department.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2