Results 1 to 5 of 5
  1. #1
    Untanglit
    Join Date
    Feb 2017
    Posts
    29

    Question Need help locking down my QoS

    I often play online video games and latency is a must.
    I've set Untangle v13 to:
    "Bypass rules" and "QoS rules" to the ports i require and set the priority to "Very high", just like a VoIP phone.
    I've set my "WAN Bandwidth" to 90%" of my connection.
    From what i understand if i "bypass" the traffic i can improve the latency since the traffic isn't being processed by any of Untangles filtering apps?

    So...
    I begin a download using my browser over port 443(set to "Medium" in Bandwidth Control), so far my game latency is fine and seems to be unaffected.

    Now i begin the same download, but instead of using my browser i use a windows application called Internet Download Manager (which oddly enough Untangle seems to identify it as IDM), i set it to download 8 streams at once per file, then my latency in my game sky rockets and my gaming experience is affected.

    I guess its the same theory behind torrenting, torrents can have 1000's of sessions happening at the same time, on a consumer router a typical torrent client could cripple it, even if you cap the speed of the torrent at the router level, its still requesting all those sessions and the rest of the traffic is stalled.

    Anyway, I can just set IDM to use 1 stream, problem solved, but is this possible to solve on Untangle? there are people on my network who also use IDM.
    Is there anything i'm missing in my configuration or some method i can use to prevent a application flooding so many streams at once?

  2. #2
    Master Untangler
    Join Date
    Aug 2016
    Posts
    239

    Default

    In your rack for Bandwidth Control could you create a rule using "Application Control: Application" is "IDM" then you can "Set a Priority" (or one of the other options)?

    Something to try ...
    Untangle 16.3.0 (Build: 16.3.0.20210507) (Kernel: 4.19.0-11-untangle-amd64)
    QOTOM-Q355G4
    1.6-2.7 GHz Intel I5 5250U, 128GB SSD mSATA, 8GB RAM DDR3L, 4xRJ-45 Intel I211AT 10/100/1000 Controller

  3. #3
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    Yes, I would just add a rule to priority IDM as "Low"
    Also make sure you are using fq_codel as the "Queue Discipline"

    Make sure your WAN limits are set correctly.
    Last edited by dmorris; 07-21-2017 at 08:27 AM.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  4. #4
    Untanglit
    Join Date
    Feb 2017
    Posts
    29

    Default

    problem solved, in the end i had to use the setting "Limited" which i believe uses 75% upload / 75% download
    i'll try and fine tune the "Limited" setting so its say 90%.
    even at the "Low" setting, IDM can still for some magic reason fully cap out my internet, even with my other rules set in place, it will still try dominate the 100% of the net.
    ng4ever likes this.

  5. #5
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    thats how "Low" works by default and probably how you want it to work.
    You want downloads to be as fast as possible unless there is something more important.
    You gain nothing by not using bandwidth - its just wasted.

    https://wiki.untangle.com/index.php/...e_7_Priorities
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2