Results 1 to 7 of 7
  1. #1
    Newbie
    Join Date
    Sep 2018
    Posts
    6

    Default Untangle's Public IP

    Hi All,

    I have installed the HomePro version of Untangle in Router mode behind a BT Modem in bridged mode on a low power PC with two network adapters.

    I've configured PPPoE and functionally all is well. The internet is working and I'm able to NAT my internal network to use my public WAN IP

    I have a bit of an issue with the public IP though, I have managed to NAT the internal Subnet to the static IP, but the untangle appliance itself just uses the DHCP address issued by BT.

    When I view Config > Interfaces > External - I have the current address as a DHCP which changes frequently.

    On the interface settings I've got IPv4 Options "NAT Traffic exiting this interface" set to enabled and I've added it (the Static WAN IP)as an alias in the Interface settings as a /32 address.

    Problem: Email reports sent from Untangled are using the DHCP WAN IP and not the static. Result is emails hitting quarantine due to SPF fail.

    How can I get the appliance to use the static IP ?

    I would be very grateful for any advice on the matter.
    Last edited by nicklove; 09-18-2018 at 09:11 AM. Reason: wrong subject,

  2. #2
    Newbie
    Join Date
    Sep 2018
    Posts
    7

    Default

    Hi, go to Config -> Hostname. You can change it from defaulting to the external/WAN IP to something else.

  3. #3
    Newbie
    Join Date
    Sep 2018
    Posts
    6

    Default

    thanks ntguru. I tried this and it worked

  4. #4
    Master Untangler
    Join Date
    May 2008
    Posts
    772

    Default

    I think the way to set the external ip would be to go to ipaddres/admin/index.do#config/network. Click edit on the external and set it to static. Then you should have your static address for what ever you wanted it.

  5. #5
    Newbie
    Join Date
    Sep 2018
    Posts
    6

    Default

    hi Donhwyo,

    With PPPoE I am unable to set a static IP. It just has what ever BT assigns for the DHCP address. I recently added another 4 static IP's to play around with Exchange and Skype. I hoped to use one of the statics for the management IP of the untangle box. So far I've been unable to do set it.

    Does anyone have any experience with BT and Untangle and 5 ip's? Be nice to have the Untangle box on the first usable.

    As it stands, I've noticed that the NAT rules just forward all traffic that hit all 5 IP's to what ever rule is configured, for example Exchange.

    cheers

    Nick

  6. #6
    Untangler
    Join Date
    Jul 2017
    Location
    Midlands, UK
    Posts
    47

    Default

    I've not had any experience with using multiple external IPs in Untangle, but I'm pretty sure from what I've been reading, you need to add the extra IPs as aliases to the External Network settings within Config -- Network.

    Then you should be able to port forward services coming in via specific external IPs by adding the "Destination Address is:" condition to your port forward rules

    So for example, if your Exchange server is supposed to be on 1.2.3.4 then make sure in your SMTP port forward rule that you add Destination Address is: 1.2.3.4
    Sam Graf and nicklove like this.

  7. #7
    Newbie
    Join Date
    Sep 2018
    Posts
    6

    Default

    Quote Originally Posted by jim1985 View Post
    I've not had any experience with using multiple external IPs in Untangle, but I'm pretty sure from what I've been reading, you need to add the extra IPs as aliases to the External Network settings within Config -- Network.

    Then you should be able to port forward services coming in via specific external IPs by adding the "Destination Address is:" condition to your port forward rules

    So for example, if your Exchange server is supposed to be on 1.2.3.4 then make sure in your SMTP port forward rule that you add Destination Address is: 1.2.3.4
    Jim... Absolutely right. Destination Address to the Port Forward rule. Thank you for taking the time.
    jim1985 likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2