this isn't much of a bug, but....

create new Access Rule; note that IPv6 is NOT checked
put a couple of conditions in the rule, click Done, and Save the rules
exit the Access Rule list, go back: see that IPv6 is now checked on your new rule

after this, you can edit the rule and uncheck IPv6 and the setting will stick

like I said, not much of a bug