Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Newbie
    Join Date
    Sep 2011
    Posts
    11

    Default Communication Between Interfaces

    I have the following setup and I need some help it with.

    interface eth0 : comcast router 10.0.0.16
    interface eth1 : dmz 192.168.2.1
    interface eth2 : internal 192.168.3.1 ( gigabit router clients using dhcp )
    interface eth3 : wifi 192.168.4.1 ( wifi router clients using dhcp with 192.168.33.x ips )

    I would like to be able to have to clients on eth2 and eth3 be able to talk/see one another but I cant seem to figure it out. Can someone tell me what I need to do to get this to work?

  2. #2
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    23,767

    Default

    The question is... what did you do to stop it? Untangle doesn't stop inter-network communications unless you tell it to.

    Did you enable the NAT boxes on any of the interfaces not aimed at the Internet?

    How are you testing? Are you using IP addresses to connect? Names? Short or long names?

    Are you using Windows? Are you aware that Windows by default has the Windows Firewall block all such communications?
    Last edited by sky-knight; 11-30-2019 at 08:57 AM.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  3. #3
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    8,175

    Default

    Post a screen capture of the interface configuration. By default all non-WANs can reach each other. A common issue is NAT is check on non-WANs. Generally it should be unchecked for non-WANs.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  4. #4
    Newbie
    Join Date
    Sep 2011
    Posts
    11

    Default

    Have not done anything, basic out of the box setup. Here is my network interfaces config:

    Untangled.jpg

  5. #5
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    8,175

    Default

    We need to see the configs for each of those interfaces.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  6. #6
    Newbie
    Join Date
    Sep 2011
    Posts
    11

    Default

    Attached.

    As I said eth3 ( WIFI ) as a wireless router attached to it that servers out DHCP with 192.168.33.x. I am using with ip address print to reach one side or the other. Both sizes have Linux boxes, so no windoze none sense is involved. I have a box on the Internal side that has a address of 192.168.3.75 that is trying to ping a box on the WIFI side that has a address of 192.168.33.2.Untangled-eth0.jpg
    Untangled-eth1.jpg
    Untangled-eth2.jpg
    Untangled-eth3.jpg

  7. #7
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    23,767

    Default

    So that router? Needs to be changed...

    It's a NAT device, and therefore anything beyond it is unreachable. Unplug its WAN interface, disable DHCP, and change it's LAN IP address to something compatible with that .4 network, like 192.168.4.2. Enable DHCP on Untangle, and now that your router is a WAP like it should be, you'll find things cooperating.

    Wireless devices will be 192.168.4, that .33 no longer exists.
    Last edited by sky-knight; 11-30-2019 at 12:25 PM.
    mtarbox likes this.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  8. #8
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    8,175

    Default

    Quote Originally Posted by jcoffin View Post
    A common issue is NAT is check on non-WANs. Generally it should be unchecked for non-WANs.
    Like I said, NAT needs to be unchecked on the non-WANs. You have it checked.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  9. #9
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    23,767

    Default

    I only see NAT checked on the WAN... But may as well have it checked on the wifi NIC, because beyond that is a wireless router that isn't configured as an access point.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  10. #10
    Newbie
    Join Date
    Sep 2011
    Posts
    11

    Default

    Only one that NAT is checked is the external one. When that is unchecked I cant ping/access things out in the world.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2