Results 1 to 3 of 3
  1. #1
    Untanglit
    Join Date
    Oct 2018
    Posts
    17

    Default No networking after v15 update

    I have untangle running in a Hyper-V VM and has been working for awhile. It is a Gen 1 VM, with dedicated memory. Version 15 updated over the weekend and it has dropped both internal and external connections. This is a home install.

    The install is pretty straightforward.
    CenturyLink router (192.168.1.0/24) --> WAN interface on Untangle (192.168.1.9, static) ----> Internal Interface on Untangle (192.168.0.1, 192.168.0.0/24, static, single subnet).

    I know I am double natted, something I have been working on, but don't think is affecting this issue.

    Everything on the host looks fine (Windows 2016). Everything looks ok in Hyper-V as well. The external interface has a dedicated NIC and the internal interface is shared with another 2 other VMs. One is a DC (W2k12) that doesn't do too much and the other is DNS, piHole. The DC is able to get out to other devices on the .0.0 network, so I am pretty sure the vSwitch in Hyper-V is working properly. It can also get to other devices on the internal network. All devices on the internal network can connect to each other. However, nothing can get to Untangle, either through the internal or external interfaces and Untangle can't get out on either side.

    In Untangle, all tests fail in the troubleshooting tab. The only time it will work, like for ping, or tracert, is if I use localhost. When running a ping, I get network is unreachable. Even using the assigned ip address for the interfaces, the tests fail. If I go into terminal and run ifconfig, I don't see a ipv4 address for either interface. I tried to switch the external interface to DHCP to see if it would pull an address from the CL router, but it doesn't.

    Something in the update borked the network adapters for untangle and I am not sure what. Any help is greatly welcomed.
    Attached Images Attached Images
    Last edited by at5147; 04-06-2020 at 12:21 PM. Reason: Added ifconfig output

  2. #2
    Untanglit
    Join Date
    Oct 2018
    Posts
    17

    Default

    I've made some minor headway on this. It seems that Untangle is not writing and/or saving the network config in Debian. I got the WAN interface to save, however, by switching it to DHCP, saving, and then back to static. It doesn't seem to want to save the DNS servers to the config file as DNS is still failing. I can get a ping out with an IP address only, but the DNS and TCP tests still fail and I can't ping by name.

    I can't get the IP config for the internal interface to save at all. I tried to disable it, save, and then enable it, but it still will not keep the address. I also think the route table may be messed up.

    I have also tried to go into the recovery tools to configure the interfaces there, but it still does not save it.

    Typed too soon. Loses config after a reboot.
    Last edited by at5147; 04-06-2020 at 01:30 PM.

  3. #3
    Newbie
    Join Date
    Sep 2019
    Location
    USA
    Posts
    6

    Default

    I've a similar problem, though my web connectivity and internal network are in tact and working fine...

    My Untangle Hyper-V VM has been working flawless but after this latest update I can't ping or web config my router--regardless of browser or OS. It's worked once or twice, after some minutes waiting, but for the most part something seems broken. Remote desktop sessions still work fine though and clients are getting IP's just fine.

    Really weird.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2