Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Dual WAN setup

  1. #1
    Untangler
    Join Date
    Aug 2018
    Posts
    42

    Exclamation Dual WAN setup

    Hallo Guys

    I am trying to get dual WAN to function with the WAN Balancer, but have a little trouble.

    UTConfig copy.jpg

    I have 2 Huawei 4G routers from different ISP's. I run in "bridge" mode. One of the routers has been configured as "external" when the installation was made with the following data:

    Untitled.png

    So my eth0 is that router and eth1 is internal.

    The LAN address of the UT box is 192.168.100.150

    So the router on eth0 is DHCP as well for the whole network.

    So I have of course disabled DHCP on the 2nd router, that I have connected. I have named it like this, but it does not seem to pick up any traffic, even if I force a computer to use it via a rule in wan balancer, so I guess there is something wrong.
    Screenshot 2021-06-07 at 06.07.15.png

    Thanks for any input on this.

    Ulf
    Last edited by UlfLaursen; 06-06-2021 at 09:22 PM.

  2. #2
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    9,628

    Default

    The LAN can not be the same network as the WAN 1. The LAN should not be in the 192.168.100.0/24 range.
    Last edited by jcoffin; 06-06-2021 at 09:44 PM.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Untangler
    Join Date
    Aug 2018
    Posts
    42

    Default

    Thanks a lot jcoffin - should I then use UT as DHCP instead, i.e on 192.168.300.0/24?

    Thanks

  4. #4
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    9,628

    Default

    Using the Untangle as the LAN DHCP is correct if you have no other DHCP servers on your LAN.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  5. #5
    Untangler
    Join Date
    Aug 2018
    Posts
    42

    Default

    Thanks again

    Just to be sure, if I configure as this it should work?

    UT box: 192.168.100.0/24 and HDCP handing out 192.168.100 addresses to clients

    Router 1: DHCP disabled, and static IP 192.168.110.100/024

    Router 2: DHCP disabled, and static IP 192.168.120.100/024

  6. #6
    Master Untangler
    Join Date
    Nov 2018
    Posts
    117

    Default

    UT box should work, as you described, but I don't know why you complicate things. Give it 192.168.1.1 in the 24 subnet which means you will have 254 available internal IP addresses. In your example it should also work but the address should be 192.168.100.1 for example.
    ROUTER 1 & 2 are wrong. Those are reserved as internal IP's. They should have external IPs, something like 8.235.64.25.
    Last edited by soldier; 06-07-2021 at 07:11 AM.

  7. #7
    Untangler
    Join Date
    Aug 2018
    Posts
    42

    Default

    Thanks for your reply.

    The 2 routers are Huawei B535 4G routers with SIM cards in to give 4G internet, so they only have 4 LAN ports.

  8. #8
    Master Untangler
    Join Date
    Nov 2018
    Posts
    117

    Default

    I understand, but they have external IP from the service provider, which is WAN IP like your normal ISP at your home (cable, fiber, ADSL, VDSL, ....). Like your phone with SIM card. It gets External IP from your mobile operator and that's how you have internet on your phone via cellular network (4G, 5G).

  9. #9
    Untangler
    Join Date
    Aug 2018
    Posts
    42

    Default

    Ok, should I give the interfaces in UT these WAN IP's then?

    Thanks

  10. #10
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,038

    Default

    Not all connections provide real routable IPs, cellular links are notorious for this.

    I'm not a fan of the double NAT involved, so in these cases I also disable NAT on the WANs. This leaves port forwarding on the cellular devices, assuming that's even possible because they too might not have a real public address. Which is yet another reason why disabling NAT is critical, in these cases you have double NAT behind carrier grade NAT if you don't! It's a great way to have things intermittently not work!
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2