Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Newbie
    Join Date
    May 2009
    Posts
    10

    Default Port forwarding for RDP

    I have rules setup for RDP. The rules work at first and then "Because of a protocol error, this session will be disconnected. Please try connecting to the remote computer again." What could be causing the forwarding to fail or be blocked.

  2. #2
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    welcome to the forums!

    can you post a screenshot of your rule.

    You can also try some suggestions here: http://wiki.untangle.com/index.php/P...shooting_Guide
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Newbie
    Join Date
    May 2009
    Posts
    10

    Default

    Here is a screenshot of one rule.

  4. #4
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    can you connect when you test with telnet?
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  5. #5
    Newbie
    Join Date
    May 2009
    Posts
    10

    Default

    I can connect through telnet. Strange issue, they just stop working. Recreated the redirect to the server and it is working now. I get the same error from the Terminal Server Client if I try to connect to a non-forwarded port. I can RDP on the local network without issue. I have tried disabling the firewall, but have no rules configured, all set to pass.

  6. #6
    Untangle Ninja raditude's Avatar
    Join Date
    Jan 2009
    Location
    Eugene, OR
    Posts
    1,143

    Default

    The RDP port is 3389, not 3391, mine works just fine when set to this, unless you changed the default port??

  7. #7
    Newbie
    Join Date
    May 2009
    Posts
    10

    Default

    Thanks, yes I've changed the default port. I have several workstations the users access with RDP. The forwarding works if I delete the rule and recreate it, but stops working some time after.

  8. #8
    Untangle Ninja raditude's Avatar
    Join Date
    Jan 2009
    Location
    Eugene, OR
    Posts
    1,143

    Default

    Can you access these systems on the LAN using RDP without any issues?

  9. #9
    Untangle Ninja Solignis's Avatar
    Join Date
    Jul 2008
    Location
    Hudson, Ohio, USA
    Posts
    1,697

    Default

    FYI, RDP only uses TCP. I doubt it really matters though.

    I think your problem is in the rules.

    I don't think you need the "Destination Port" option, just the protocol and the information at the bottom. The firewall might be getting "confused". I know for a fact on a computer that is trying to connect to a computer via RDP it does not use 3391 in your case, That is the port that is used to locate the computer and for outbound traffic. MSTSC uses a random port to connect to the destination computer. The one time I was looking at my firewall logs I think my desktop was using 34992(I guessing, I don't remember). I do the same thing around our office that you are doing. I went into the registry and changed atleast a half dozen ports for people to get in from their houses.

    Hope this is of some help.
    “Most good programmers do programming not because they expect to get paid or get adulation by the public, but because it is fun to program.” - Linus Torvalds

  10. #10
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,542

    Default

    You do realize that Untangle has the "destination port" field... so you can forward whatever port you want publicly to internal 3389 and avoid hacking registries outright?

    Still I can't explain why a port forward would work for a short time and bail... that is new.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2