Results 1 to 10 of 10
  1. #1
    Untanglit
    Join Date
    May 2017
    Posts
    17

    Question VOIP with WAN balancer results in one way audio for some calls.

    I have a couple sites that use cloud based VOIP. These sites have multiple wans and I am using the balancer. The issue we are experiencing involve no sound after a call picks up(inbound). Disabling the second wan interface solves this 100% at both locations. Its not every call, but maybe 50% of the calls can only hear audio in one direction.

    Have any of you experienced this with WAN balancer? I was going to create route rules for all the phones but that doesn't help if one of the ISP's goes down. Ideas?

    Thanks in advance,

    -Christopher

  2. #2
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Lake Tahoe
    Posts
    9,655

    Default

    https://support.untangle.com/hc/en-u...shooting-Guide

    Bypass VOIP traffic is the best solution.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Untanglit
    Join Date
    May 2017
    Posts
    17

    Default

    Ok, so despite having the default SIP rules we add bypass for all VoiP phones(static ip range) for both incoming and outgoing connections to these IP's, and make sure QoS is enabled? I will try this tonight and see if that allows me to re-enable WAN balancer.

    Thanks!

  4. #4
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Lake Tahoe
    Posts
    9,655

    Default

    Quote Originally Posted by Haahof View Post
    Ok, so despite having the default SIP rules we add bypass for all VoiP phones(static ip range) for both incoming and outgoing connections to these IP's, and make sure QoS is enabled?
    Thanks!
    That how I run my network
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  5. #5
    Untanglit
    Join Date
    May 2017
    Posts
    17

    Default

    Yeah, no change. Added bypass rules for the IP range that contains the phones. QoS is on and configured. When WAN Balancer is enabled, inbound calls get dead air. Disable the balancer? everything works fine. The problem is we have the second ISP specifically for the phones!

    Any other suggestions?

  6. #6
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Lake Tahoe
    Posts
    9,655

    Default

    Correct, make VOIP sticky to one WAN.

    wan-sticky-voip.png
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  7. #7
    Untanglit
    Join Date
    May 2017
    Posts
    17

    Default

    I appreciate the continued feedback on this, and I've opened up a ticket with support. Doesn't sticking all VoiP traffic onto one WAN defeat the purpose of the balancer/fail over?

  8. #8
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Lake Tahoe
    Posts
    9,655

    Default

    Failover will still occur. Unfortunately separate WANs for VOIPs sessions breaks UDP sessions. You can separate half of the VOIPs to each WAN if bandwidth is an issue.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  9. #9
    Untanglit
    Join Date
    May 2017
    Posts
    17

    Default

    I spoke with the phone vendor... They are going to switch the VoiP traffic from UDP to TCP which should allow the balancing to happen without issue. Interestingly enough, they mentioned that this is a common issue for them and are working on a solution that allows for some level of state fullness over UDP. Fingers crossed, and thanks for the help, J.

  10. #10
    Untangler
    Join Date
    May 2008
    Posts
    520

    Default

    There is a reason voip should be udp. Udp drops late packages. Tcp waits for them.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2