Results 1 to 6 of 6
  1. #1
    Master Untangler
    Join Date
    Dec 2017
    Posts
    111

    Default Time Server NTP DNS instead of IP

    As the title indicates; is there a way to set the NTP server as a DNS i.e. time.google.com and another few instead of being forced to give the ip addresses for the NTP server? Reason being I guess the servers change IP addresses every so often, and it would be nice to just use the DNS name instead.

  2. #2
    Untangler
    Join Date
    Mar 2018
    Location
    Toronto, Ontario
    Posts
    53

    Default

    Quote Originally Posted by flynhawaiian View Post
    As the title indicates; is there a way to set the NTP server as a DNS i.e. time.google.com and another few instead of being forced to give the ip addresses for the NTP server? Reason being I guess the servers change IP addresses every so often, and it would be nice to just use the DNS name instead.
    Hi,
    Well, it should be an FQDN and not ip address for NTP servers to begin with. In fact ntp.org encourages you to use pool.ntp.org and using that on my ntp server under untangle's lxc (linux container), responds with 4 servers coming back and is currently synchronizes with time.0xt.ca.

    root@client:~# chronyc sources
    210 Number of sources = 4
    MS Name/IP address Stratum Poll Reach LastRx Last sample
    ===============================================================================
    ^- time.cloudflare.com 3 10 377 1021 -1169us[-1269us] +/- 16ms
    ^- ip102.ip-198-27-76.net 2 10 377 782 +1281us[+1181us] +/- 71ms
    ^* time.0xt.ca 2 10 377 675 -645us[ -745us] +/- 6982us
    ^- serenity.baxterit.net 2 10 377 754 +2925us[+2825us] +/- 42ms

  3. #3
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,163

    Default

    yeah but all the DNSMasq documentation I've seen references an IP.

    I'd try simply replacing the IP with the FQDN to see if it works, but I haven't used Untangle in this manner. I've never needed to set option 42.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  4. #4
    Master Untangler
    Join Date
    Dec 2017
    Posts
    111

    Default

    Interesting. I've been having problems with it passing on the information to devices. I've been using DHCP 42 in DNSMASQ to pass the information. For some reason it doesn't pass it when using DHCP without option 42.

  5. #5
    Master Untangler
    Join Date
    Dec 2017
    Posts
    111

    Default

    Quote Originally Posted by sky-knight View Post
    yeah but all the DNSMasq documentation I've seen references an IP.

    I'd try simply replacing the IP with the FQDN to see if it works, but I haven't used Untangle in this manner. I've never needed to set option 42.
    I've been stuck with 42; not sure why it won't pass on the server information.

  6. #6
    Untangler
    Join Date
    Mar 2018
    Location
    Toronto, Ontario
    Posts
    53

    Default

    Quote Originally Posted by flynhawaiian View Post
    Interesting. I've been having problems with it passing on the information to devices. I've been using DHCP 42 in DNSMASQ to pass the information. For some reason it doesn't pass it when using DHCP without option 42.
    Somewhat been that route before. And think you know this. Even if dhcp client can retrieve the ntp information from dnsmasq, it will not automagically work since you need to install and/or configure ntp client in Linux or Windows.

    Linux: install ntp client or chronyc
    Windows: regedit to change time.windows.com to pool.ntp.org.

    Got tired of it all and just configure untangle to MITM, errr, I mean silently redirect all NTP (port 123, udp) to my own NTP server(using pool.ntp.org) running under untangle's lxc container with the already existing pihole that I have.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2