Results 1 to 5 of 5

Thread: Swap question

  1. #1
    Untangler
    Join Date
    Aug 2016
    Posts
    75

    Default Swap question

    I have a question about swap. I undersand that swap may be used at times however I am curious why after 4 days the swap space on my u150 shows as ~28% used (~870MB used).

    The specs are as follows:
    Model: Untangle u150
    CPUCount: 2
    CPU Type: Pentium(R) Dual-Core CPU E5300 @ 2.60GHz
    Memory: 4.1 GB
    Hard Drive: 231.69 GB

    Current consumption:
    Screen Shot 2021-11-28 at 9.37.20 PM.png

    Any insight into why the high swap usage (for home use) is appreciated.

  2. #2
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,514

    Default

    Linux will use RAM to cache your entire filesystem if it can and has nothing else to do with it. Swap is used similarly.

    I see nothing in these numbers to be concerned about.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  3. #3
    Untangler
    Join Date
    Aug 2016
    Posts
    75

    Default

    I appreciate the late reply!

    It was more of me being curious as to what appears to be high swap utilization.

    The device is working without issue and I have observed no latency, slowness, etc.

    Thanks again!

  4. #4
    Untangle Ninja jcoehoorn's Avatar
    Join Date
    Mar 2010
    Location
    York, NE
    Posts
    1,948

    Default

    This was high swap in 2003. In 2021, it's completely normal for any linux-based system.
    Five time Microsoft ASP.Net MVP managing a Lenovo RD330 / E5-2420 / 16GB with Untangle 16.5 to protect a 1Gbps fiber link for ~450 residential college students and associated staff and faculty

  5. #5
    DJR
    DJR is offline
    Newbie
    Join Date
    Apr 2020
    Posts
    10

    Default

    Quote Originally Posted by jcoehoorn View Post
    This was high swap in 2003. In 2021, it's completely normal for any linux-based system.
    Default alert for Swap is 25%. Should we maybe set to a higher value? How much swap is acceptable now? Have a Z4+ with only 40% memory in use, 9% disk usage, it is alerting with over 25% swap usage at times. Happened at 2:00 AM on December 12th. Currently shows swap is only 22% when I checked this morning.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2