Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Master Untangler
    Join Date
    Mar 2020
    Location
    UK
    Posts
    121

    Default Modem mgmt interface access

    I've done this before with pfsense, but trying to do it with Untangle. I've got a Draytek ADSL Modem that is in bridge modem and I'm trying to expose it's management interface from Untangle.

    I've added an alias to the WAN interface within the same IP subnet as the Draytek 192.168.2.0/24 subnet.

    I can ping the device from Untangle when that's configured, but can't access it from the internal LAN. I can see a route has been added to the routing table, but still can't access it.

    My last thought it to look at NAT / port forwarding areas relating to this, but anyone else running v16.x and successfully got the above config working?

    I've seen previous posts for older versions of Untangle and the posts are locked too.

  2. #2
    Master Untangler
    Join Date
    Jul 2010
    Location
    Nanaimo B.C
    Posts
    703

    Default

    Um, if it is in bridge mode then how are you getting a 192 address ? Bridge mode should give you a WAN address on your Wan port.
    Started Youtube Channel, Have a question about Untangle Ask me : jason @ jasonslab.ca
    https://www.youtube.com/c/jasonslabvideos << Please like and subscribe, helps me out !!

  3. #3
    Master Untangler
    Join Date
    Mar 2020
    Location
    UK
    Posts
    121

    Default

    Quote Originally Posted by dashpuppy View Post
    Um, if it is in bridge mode then how are you getting a 192 address ? Bridge mode should give you a WAN address on your Wan port.
    I have a WAN address on the PPOE interface, but the modem still has an active interface on 192.168.1.2, which I can access if plug into the same switch etc.

  4. #4
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,482

    Default

    The problem with this stuff is you're having to guess how the firewall on the modem is configured, some of them are quite picky.

    I'd start by bypassing traffic destined to the IP of the modem to get any layer 7 filters out of the way, and follow that up with a custom NAT policy to ensure all traffic destined to the WAN interface in question, and destined to the IP of the modem, is manually translated to the 192 address on the WAN.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  5. #5
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Lake Tahoe
    Posts
    9,650

    Default

    Add an IP alias to the WAN in the same range as the modem management (192.168.2.2? guessing). Check that the alias does not conflict with existing IP ranges on your NGFW. Once saved, you should be able to access the modem management interface from the LAN
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  6. #6
    Master Untangler
    Join Date
    Mar 2020
    Location
    UK
    Posts
    121

    Default

    Quote Originally Posted by jcoffin View Post
    Add an IP alias to the WAN in the same range as the modem management (192.168.2.2? guessing). Check that the alias does not conflict with existing IP ranges on your NGFW. Once saved, you should be able to access the modem management interface from the LAN
    Not able to, but I can ping it from Untangle FW following that change. I had that configured before posting here and thought what am I missing etc.

    I'll have a dig around on both devices.

  7. #7
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Lake Tahoe
    Posts
    9,650

    Default

    Either there is a route for that network already present or the modem limits connects to direct networks (no NAT).
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  8. #8
    Master Untangler
    Join Date
    Mar 2020
    Location
    UK
    Posts
    121

    Default

    Quote Originally Posted by jcoffin View Post
    Either there is a route for that network already present or the modem limits connects to direct networks (no NAT).
    Can't find any restrictions on the modem and I didn't have to make changes with pfsense, but the pfsense process is different. 192.168. is not in use on this network.

  9. #9
    Untangler
    Join Date
    May 2008
    Posts
    518

    Default

    There is a "filter rule" "Block outbound traffic to 192.168.0.0/16 (RFC1918)". Is it enabled enabled?

  10. #10
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,482

    Default

    Quote Originally Posted by mikeyscott View Post
    Can't find any restrictions on the modem and I didn't have to make changes with pfsense, but the pfsense process is different. 192.168. is not in use on this network.
    You won't see the restrictions, they're always hidden and hard coded if they exist.

    And, just like PFSense it should "just work". The most I've had to do is make the alias as you've suggested, because the WAN interface NAT's by default.

    So once again I'm back to suggesting a bypass rule, because the only think I can think if is one of your apps filtering it.
    dashpuppy likes this.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2