Results 1 to 5 of 5
  1. #1
    Untangler swmspam's Avatar
    Join Date
    Mar 2008
    Posts
    71

    Default Help with a Debian box sending mail

    Off topic question:

    I have a Debian box that I want to send an email message from the command line. I have tried the better part of a day on this with no success. The following code should send an email to my ISP account with the subject line "Test Subject Line":

    Code:
    mail -s "Test Subject Line" myname@myISP.com </dev/null
    My ISP uses SMTP authentication.

    Any suggestions?

  2. #2
    Untangle Ninja mrunkel's Avatar
    Join Date
    Jul 2008
    Posts
    3,022

    Default

    run 'dpkg-reconfigure exim4-config'
    and answer the questions correctly.

    That should help you get your box to send mail properly.
    m.
    <BR>
    Big Frickin Disclaimer:
    While I'm pretty sure, I can't guarantee that I know what I'm doing. There might be a better way to do this, and this way might actually suck. Make sure you understand the implications of what you're doing before trying to follow these directions.
    <BR>It often helps troubleshooting if you have a good network map. Look <A HREF="http://forums.untangle.com/tip-day/5407-how-draw-network-diagram.html">here</A> if you want my advice on how to draw one. <BR> <B>Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com<B>

  3. #3
    Untangler swmspam's Avatar
    Join Date
    Mar 2008
    Posts
    71

    Default

    I fought the exim4 battle and lost. Uninstall, purge, delete any leftover files, and reinstall.

    In all cases, the package configuration screen does not allow an entry on the following (critical) screen:

    Code:
       тттттттттттттттттттттттттттттттттттттттттттттттттттЄ Mail Server configuration ттттттттттттттттттттттттттттттттттттттттттттттттттт
       т Please enter the IP address or the host name of a mail server that this system should use as outgoing smarthost. If the       т
       т smarthost only accepts your mail on a port different from TCP/25, append two colons and the port number (for example          т
       т smarthost.example::587 or 192.168.254.254::2525). Colons in IPv6 addresses need to be doubled.                                т
       т                                                                                                                               т
       т If the smarthost requires authentication, please refer to the Debian-specific README files in /usr/share/doc/exim4-base for   т
       т notes about setting up SMTP authentication.                                                                                   т
       т                                                                                                                               т
       т IP address or host name of the outgoing smarthost:                                                                            т
       т                                                                                                                               т
       т _____________________________________________________________________________________________________________________________ т
       т                                                                                                                               т
       т                                     <Ok>                                         <Cancel>                                     т
       т                                                                                                                               т
       ттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттттт
    Maybe I missed a configuration file somewhere that is causing me problems.

    Unless the package configuration is fixed, the only way is to manually edit the exim4 config files - and I haven't found a clear explanation to do this.

  4. #4
    Untangler swmspam's Avatar
    Join Date
    Mar 2008
    Posts
    71

    Default

    Wow. That was a particularly nasty problem.

    /etc/exim4/update-exim4.conf.conf had become corrupt with non-visible characters and therefore locked out several of the functions dpkg-reconfigure exim4-config. In addition, a user permission wasn't correct.

    This was one of the more difficult times I've had with Linux.

  5. #5
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,510

    Default

    It's a double .conf for the win!
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2