Results 1 to 2 of 2
  1. #1
    Newbie
    Join Date
    Sep 2009
    Posts
    1

    Post Client 2 Server - TLS handshake failed

    Howdy,

    I've recently reinstalled Untangle on my firewall, and OpenVPN was working fine without any problems for several weeks. Two days ago I've changed the local gateway in our network to force everyone going through the UT firewall again and VPN was still working. This morning I tried to establish a VPN connection and was getting the error, that TSL handshake has failed.

    I've also tried restarting firewall and openvpn services and have also created a new client certificate, but the problem still persists.

    User --> Internet --> ADSL-Modem (no router) --> Untangle Firewall

    Code:
    Fri Sep 25 09:06:58 2009 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
    Fri Sep 25 09:06:58 2009 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
    Fri Sep 25 09:06:58 2009 LZO compression initialized
    Fri Sep 25 09:06:58 2009 UDPv4 link local: [undef]
    Fri Sep 25 09:06:58 2009 UDPv4 link remote: ***.***.***.***:1194
    Fri Sep 25 09:07:58 2009 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Fri Sep 25 09:07:58 2009 TLS Error: TLS handshake failed
    Fri Sep 25 09:07:58 2009 SIGTERM[soft,tls-error] received, process exiting
    Any ideas? Thank you very much.

  2. #2
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,497

    Default

    That error is usually an authentication issue. When it shows up I reissue the certificate to the client in question and it goes away.

    Another thing it can be is the port not being open, commonly caused by a goofed port forward.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2