Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,555

    Default

    Untangle in router or bridge mode? Assuming Untangle is in router mode, is the UPS server using Untangle as its default gateway?

    If Untangle is in bridge mode, did you configure a static route for the OpenVPN Address pool in your gateway?
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  2. #12
    Newbie
    Join Date
    Jan 2012
    Posts
    7

    Default

    It is in router mode I am not using untangle DHCP server and overing DNS (push domain DNS server). Yes the UPS server is set to use Untangle as gateway. I thing I found was in the Bypass Rules > Bypass DNS Traffic is UNCHECK is that correct?

  3. #13
    Untangler
    Join Date
    Jun 2010
    Posts
    44

    Default

    Make sure you're using the latest version of the OpenVPN client (2.2.2 as of this writing). I sometimes work from home and last week, 2.2.1 would not connect to the SQL servers at work. I found an internet post somewhere stating that upgrading to 2.2.2 fixed it for them; well, 2.2.2 fixed it for me as well.

    No configuration changes were made on the Untangle OpenVPN server or on the OpenVPN client prior to the 2.2.2 upgrade.

    - Joe

  4. #14
    Newbie
    Join Date
    Jan 2012
    Posts
    7

    Default

    The client was using 1.0.3 I did update him to 2.2.2, he reporting faster speeds but UPS still fails. with the same error.

  5. #15
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,555

    Default

    SSH to Untangle

    tcpdump -i eth1 port 1434

    Have client open software, watch the packets fly. If you see stuff exiting eth1 (default internal interface) Untangle did its job.

    Also, MSSQL operates over the TCP protocol with a default port configuration of 1433.

    http://support.microsoft.com/kb/287932

    Changing the port is irrelevant, but the protocol is a huge change. And I suspect due to that you may have been formatting rules for the wrong protocol.

    Is this the only user of the software attempting this process? Do you have any other users of the software that aren't on the local ip network? If all other users are on the IP network you may have an issue with your TCP/IP settings for the MSSQL server. Everyone on the local network can fall back to named pipes and appear to work normally when in fact they are broken.

    If the server is on Windows Server 2008 you may have some Windows Firewall work to do.

    All the more reason to read the output of TCPDump. If you see packets from the VPN user, exiting the Internal interface, and you don't see a response, your issue is on that server, not Untangle.

    Stop guessing, start troubleshooting!
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  6. #16
    Untangler
    Join Date
    Oct 2008
    Posts
    84

    Default

    any resolution to this? I'm having the same issue. Cant connect to a program through VPN but works just fine on the local network. Program uses SQL :/

  7. #17
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Lake Tahoe
    Posts
    9,766

    Default

    Quote Originally Posted by orange View Post
    any resolution to this? I'm having the same issue. Cant connect to a program through VPN but works just fine on the local network. Program uses SQL :/
    This is probably a configuration issue. I suggest creating a new thread for you situation and add more information about your configuration. With VPN problems, it's best to see if the packet are going through the right interface with tcpdump on the Untangle terminal.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  8. #18
    Untangler
    Join Date
    Oct 2008
    Posts
    84

    Default

    I'm pretty sure its the same issue. I can connect the VPN and do everything (RDP, network shares, etc) but cant access SQL. For anyone that finds this thread like I did, upgrading openvpn to 2.2.2 fixed it for me!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2