We are planning to setup the following site-to-site VPN:

Main Site: Untangle on VMware
Remote Site 1: Embedded Ubuntu with OpenVPN version 2.0.9
Remote Site 2: Embedded Ubuntu with OpenVPN version 2.0.9

Questions:
1. Will the above be possible, considering that we won't be able to upgrade the OpenVPN version on Ubuntu?
2. If yes, would it be safe to say that allowing untangle to auto-upgrade should not result in incompatible OpenVPN partners, thereby no links?

Thanks in advance.
Regards,
Ranley