Results 1 to 4 of 4
  1. #1
    Untangler
    Join Date
    Jan 2011
    Posts
    76

    Default OpenVPN Generated Client Certificate Blank

    Hi,

    Been using OpenVPN for years now, but just ran into the issue of certs not being strong enough for the latest version of the OpenVPN client. As per advice on the forum, uninstalled the OpenVPN module, then re-installed. I then added a new client endpoint, and downloaded the configuration (for 'other' target systems) ZIP file.

    The zip file contains the config and client cert, key and CA certificates, however the client .crt certificate file is empty (Zero Bytes)..., what's going on here ? bug ?...

    Thanks.

  2. #2
    Untangler
    Join Date
    Jan 2011
    Posts
    76

    Default

    Answer: The client name had and underscore in it..., so 'phil_mobile' generated no client certificate (no error messages about this), while 'philmobile' worked fine...
    Last edited by tescophil; 07-07-2017 at 05:40 AM.

  3. #3
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    9,294

    Default

    Thanks for the update. The username validation is planned for the next release. https://jira.untangle.com/browse/NGFW-10797
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  4. #4
    Newbie
    Join Date
    Jun 2017
    Posts
    3

    Default

    I have found that _ does not work but - does. I have all my clients set up with a dash now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2