Results 1 to 6 of 6
  1. #1
    Newbie
    Join Date
    Mar 2018
    Posts
    6

    Default java.lang.RuntimeException: Failed to start OpenVPN daemon - Client: 13.2 Server: 9.4

    I get the error "java.lang.RuntimeException: Failed to start OpenVPN daemon" when trying to import a config file from an Untangle 9.4.2 server into a 13.2.0 client.
    I may have created this problem by my actions. I was able to import a config file from the 9.4 box once and enable OpenVPN but it would not connect to the server. Thinking it may have been a problem with the settings on the 9.4 box that caused the connection to fail, I deleted the first client entry from the 13.2 box, generated a different config file on the 9.4 box and tried to import the new file on the 13.2 client. Since removing the first setup, when I try to import a new config file I receive the "java.lang.RuntimeException: Failed to start OpenVPN daemon" error. (Sometimes a second attempt to import the config file seems to work (if the OpenVPN app is "off") but I cannot turn the OpenVPN app "on" without generating the error.
    I have tried removing and reinstalling the OpenVPN app, rebooting the appliance, and even running a "restore to factory defaults" command, but I still receive the same error.

    Is it possible that there is a residual file from my previous 9.4 config import that can be conflicting with the new config file? Is it still possible to successfully OpenVPN between 9.4 and the current version?

  2. #2
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    Unfortunately v9.4 is not current and should be reinstalled immediately.
    It is not receiving security updates and is not compatible with new versions.
    Last edited by dmorris; 03-15-2018 at 06:03 PM.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Newbie
    Join Date
    Mar 2018
    Posts
    6

    Default

    Will I likely have any residual problems with the OpenVPN app on the 13.2 appliance because of this ill-advised configuration attempt?

  4. #4
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    Nah, I don't think so. I assume you're getting that error on v9.4?
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  5. #5
    Newbie
    Join Date
    Mar 2018
    Posts
    6

    Default

    The error appears on the 13.2 box. (When I tried to import the file from the 9.4 server.)

  6. #6
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    25,095

    Default

    I would assume your worse case would be to remove the OpenVPN module, and reinstall it.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2