Results 1 to 4 of 4
  1. #1
    Newbie
    Join Date
    Jul 2018
    Posts
    3

    Default Using OpenVPN in TCP Mode

    I'm unable to make OpenVPN on Untangle work in TCP mode.
    I have the latest version of Untangle installed.

    I have it up and running in UDP mode right now, but we have sales people that are located in Europe and India that are having connection problems (they keep getting disconnected).
    Based on what I have read about OpenVPN, UDP is great for speed and TCP is better for stability. Stability is the reason I am trying to configure OpenVPN to use TCP.

    The only change made to the OpenVPN server side was to set the Protocol to TCP, save and restart the service.

    The .ovpn file used on the client is the same file that was created/deployed with the client install, with a few changes noted below.

    Example .ovpn file on client (with cert info removed....):

    client
    resolv-retry 20
    keepalive 10 60
    nobind
    mute-replay-warnings
    remote-cert-tls server
    compress lz4
    verb 1
    persist-key
    persist-tun
    dev tun
    auth-user-pass
    explicit-exit-notify 0 # changed from 1 to 0
    proto tcp # changed from udp to tcp
    port 1194
    cipher AES-128-CBC

    When the client attempts to connect, it displays “Attempting to establish TCP connection” and just sits there (times out and tries again).
    Also, telnet to port 1194 on the external address of the router does not connect. Seems the port is not open.

    Are there some other settings client or server side that need to be made to run OpenVPN in TCP mode ?

    Thanks !

    P.S.: I moved this post to its own thread from another that may not be the same issue.
    Last edited by AmigaDriver; 03-24-2020 at 12:31 PM.

  2. #2
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    8,542

    Default

    Did you add a access rule to allow TCP on OpenVPN in Config -> Network -> Advanced --> access rules?

    Similar to this one but TCP.

    openvpn-access-rule.jpg
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Newbie
    Join Date
    Jul 2018
    Posts
    3

    Default

    Hey jcoffin,

    I have not done this.
    I'll try it and let you know if it works.

    Thanks for the fast response !

  4. #4
    Newbie
    Join Date
    Jul 2018
    Posts
    3

    Default

    jcoffin,

    Adding another rule that allows TCP fixed the connection issue.
    Connection is up and stable now in TCP mode !

    Thanks for the quick help !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2