Results 1 to 4 of 4
  1. #1
    Newbie
    Join Date
    Dec 2020
    Posts
    12

    Question OpenVPN between untangle and pfsense

    Hi,

    I need to setup a site-to-site tunnel between two sites(one is untangle and the other one is pfsense). My goal is to have the untangle as a server and pfsense as a client.

    What I've did for now:
    Generate a new remote client for openvpn, like:
    Client name: something
    Group: default group
    Type: network
    RemoteNetworks: 192.168.100.0/24 (<< subnet already present on pfsense side)

    On pfsense:
    I've imported the certificate as mentioned in openvpn websit, from the ovpn file generated above:
    openvpn.net/cloud-docs/using-openvpn-cloud-profile-to-configure-pfsense

    I've added an client on openVPN->client like:
    Peer to peer(ssl/tls)
    Peer Certificate(the one added above)
    Client Certificate(the one added above)
    Enable data encription
    AES-128-CBC
    NO hw accel
    IPv4 Tunnel Network: same like the one set on untangle(172.20.218.0/24)
    IPv4 Remote networks: 192.168.3.0/24, 192.168.2.0/24

    Untangle shows that a client is connected;
    Pfsense shows that tunnel is up and running;

    On pfsense there is no traffic received from untangle

    Ping not working(not even to lan interfaces from untangle).

    What do I do wrong here ?

    Thank you!

  2. #2
    Newbie
    Join Date
    Dec 2020
    Posts
    12

    Default

    I see in logs:

    Options error: Unrecognized option or missing or extra parameter(s) in [PUSH-OPTIONS]:1: register-dns (2.5.2)

    Is this the reason of failure ?

    How should I adjust this error ?

    Other suspect logs:
    Bad LZO decompression header byte: 251

  3. #3
    Newbie
    Join Date
    Dec 2020
    Posts
    12

    Default

    I've adjusted the Auth digest algorithm to use SHA1 and now the traffic looks like bellow. However, the problem still persists.
    2021-10-18 18_31_26-murgeni.ddns.com - Status_ Dashboard.png

  4. #4
    Newbie
    Join Date
    Dec 2020
    Posts
    12

    Default

    I've been able to make it work by excluding from untangle, on advanced openVPN tab, the push option and the compress option.

    Now the VPN tunnel is stable and I'm able to use it...

    The traffic is like in the picture...2021-10-19 12_43_54-Window.png
    Last edited by Catalin; 10-19-2021 at 04:08 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2