Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Newbie
    Join Date
    Sep 2014
    Posts
    7

    Question Wrong year on reports?

    I'm wondering if anyone else is noticing this.
    On my reports page it shows the year as 2016, but my time period selected is 2015. I see this happening on a customer's setup also.
    Here's what we have:
    Build: 11.2.1~svn20151217r41939release11.2-1wheezy
    Kernel: 3.2.0-4-untangle-686-pae
    UT reports.png
    Anyone else experience this or know how to fix? I did some searching and couldn't find anything.

    Thanks!

  2. #2
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    9,466

    Default

    Yeah, I see the same issue. I believe it is related to this bug.

    https://bugzilla.untangle.com/show_bug.cgi?id=12682
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Untangle Ninja Jim.Alles's Avatar
    Join Date
    Jul 2008
    Location
    Central PA
    Posts
    2,606

    Default

    Quote Originally Posted by billjara View Post
    I'm wondering if anyone else is noticing this.
    yup.

    It is throughout reports. The start date has to be changed to show any data. The End date seems to misinterpret today and yesterday to be in 2016.

  4. #4
    Newbie
    Join Date
    Sep 2014
    Posts
    7

    Default

    So what's the workaround for this?
    Set the end date correctly and the start date to a year previous?

  5. #5
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    9,466

    Default

    The workaround is to set the date manually instead of using the "one day ago" default.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  6. #6
    Newbie
    Join Date
    Sep 2014
    Posts
    7

    Default

    Thanks got it.

  7. #7
    Untangle Ninja Jim.Alles's Avatar
    Join Date
    Jul 2008
    Location
    Central PA
    Posts
    2,606

    Default

    Quote Originally Posted by billjara View Post
    So what's the workaround for this?
    Set the end date correctly and the start date to a year previous?
    no, there is a sanity check, the year previous in the end date generates nothing.
    Just setting the start date at least two days previous gets more than a years worth of date range, but you can see the current data at least.

  8. #8
    Newbie
    Join Date
    Jan 2015
    Posts
    4

    Default

    The old reports are working fine, it's just the new reports that don't have a handle on what the "Present" is.

  9. #9
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    Yeah, sorry about that!
    You can run this command at the terminal to fix it:

    Code:
    curl -q http://untangle.com/download/patches/11.2/report-end-of-year-fix-patch.sh | dash
    Last edited by dmorris; 12-29-2015 at 12:49 AM.
    Jim.Alles and darrelahll like this.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  10. #10
    Untanglit Donald1952's Avatar
    Join Date
    Apr 2009
    Location
    United States
    Posts
    19

    Default

    Will this patch be included in an upcoming release via automatic downloads? The reason I am asking is because when loggin in to the terminal you get the warning..."This will violate your warranty....." Ooooh. I would just rather have this accomplished via the normal update process.

    Just my 2 cents.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2