Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Newbie
    Join Date
    Nov 2008
    Posts
    7

    Default Exception! Cannot read property 'list' of null / Empty Dashboard Boxes

    I'm hoping this is the correct area to post this query. Here's my situation. I recently noticed that I had a pending update on my Untangle FW 14.2 box. I applied the update, and upon reboot, I get the following error when viewing the Dashboard:

    "Exception! Message: Cannot read property 'list' of null."

    Many of the blocks on the Dashboard (Top X, Sessions, Alert Events, Spam Ratio, etc) are blank and say "please wait" indefinitely. The report emails also contain large empty chunks and are now oddly formatted.

    If I disable the report module, the error vanishes, but obviously I lose the info blocks on the Dashboard. Assuming the update borked something, I downloaded the 14.2.1 ISO and reinstalled. I then restored my backup. And oddly I get the same results. I'd REALLY rather not start from scratch since my setup is complicated and took an age of trail and error to get setup, but I'm rather stumped at where to go from here. Any insight is appreciated. I'm happy to provide whatever logs or additional info my be useful.
    Last edited by BadServo; 08-26-2019 at 08:12 AM. Reason: typos

  2. #2
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    23,680

    Default

    Anytime you see this error, your first task is to flush your browser cache.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  3. #3
    Newbie
    Join Date
    Nov 2008
    Posts
    7

    Default

    Thanks for the reply. Clearing my data in my usual browser (Chrome) changed nothing. For good measure, I also tried clearing my data in Firefox and trying there. Interestingly, Firefox gives me a different error:

    Exception! Message: Rpc.directData(...) is null

  4. #4
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    8,129

    Default

    Trying installing Policy Manager and see if the error is resolved. If not open a support ticket.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  5. #5
    Newbie
    Join Date
    Nov 2008
    Posts
    7

    Default

    jcoffin: That did it. Thanks so much for the help, mate. Everything appears correctly now.

    Quote Originally Posted by jcoffin View Post
    Trying installing Policy Manager and see if the error is resolved. If not open a support ticket.

  6. #6
    Newbie
    Join Date
    Nov 2017
    Posts
    12

    Default

    Is there a fix for this issue other than installing policy manager? It fixes the problem for me, but generally I prefer disabling functions I'm not actively using.

  7. #7
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    8,129

    Default

    It's fixed in 14.2.2 so just upgrade.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  8. #8
    Newbie
    Join Date
    Nov 2017
    Posts
    12

    Default

    Thank You. I can confirm it is resolved with 14.2.2.

  9. #9
    Newbie
    Join Date
    Nov 2019
    Posts
    1

    Default

    Now if I can only find a list of reported bugs in 11.1.2. I am trying to complete an upgrade from 10.2.1 to 11.1.2 and have two errors and one issue remaining.

  10. #10
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    23,680

    Default

    1.) You need to start your own thread.
    2.) The number of OS upgrades between 10.2.1 to current (14.2.1) is three, unless your configuration is exceptionally complicated a nuke and pave would be faster time wise, and far simpler technically.
    3.) The OpenVPN module has basically been lobotomized between then and now, so if you're using that you're going to have to nuke the module and start over there regardless of the process you use.
    4.) Welcome to the forums.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2