Results 1 to 5 of 5
  1. #1
    Untangler
    Join Date
    Feb 2018
    Posts
    66

    Default Report Exports Broken in v15?

    I routinely export a couple of event list reports to csv files for use in Excel. Until today, the number of events displayed on the screen did not impact the number of records exported. As of now, the number of exported records will not exceed the number displayed on the screen. Some of my exports are more than 100,000 records long, so setting the display number to its max of 50,000 is not sufficient to export all of the data I want to see (not to mention displaying all those really slows the interface down).

    I am not sure when the upgrade occurred, but today I am running v15.0.0, so I suspect the upgrade took place last night. Can someone please confirm whether v15 has changed the export behavior, and/or hopefully provide a workaround for this issue. Many thanks,

    ~bd

  2. #2
    Untangler
    Join Date
    Feb 2018
    Posts
    66

    Default

    Another new and unfortunate behavior I've discovered is that adjusting report columns to be displayed for a single Network report is no longer working. Changes made affect all reports in the group, for both the displayed and exported data. Thankfully the SQL rules still are still applied on a per report basis.
    Last edited by bdoster; 02-29-2020 at 03:21 PM.

  3. #3
    Untangler
    Join Date
    Feb 2018
    Posts
    66

    Default

    Hmmm.... nearly 400 views and yet I'm still the only participant in this thread. So... not enough info? Nobody else cares? No one exports large reports? No one changes their report data fields?

    Both problems really exist... exports to csv only export exactly what is on the display screen and changes to the report fields in one report affect all Event List reports (at least in the Network category of reports). Neither was the case prior to Untangle v15. Here are some details on what I am doing...

    I have a custom report based on the All Sessions report, with the only change being a SQL condition = '[Filter Prefix] is null'. For years I've exported this report with the Since: criteria set to Yesterday. Regardless of how many records are displayed on the screen (usually the default 1000), on a normal day the export produces about 130000 records. Since v15, I have to set the display to 50000 events and run the report 3 times to get the same information, then combine, sort and remove duplicates from the exported files.

    To duplicate the second issue, just change the fields displayed for any report and you'll see easily enough that all Event List reports will mirror the change. I used to have custom fields displayed on a per report basis, but not anymore.

    I am a free license user, so I don't think I can open a Support incident. Given that, what else can I do to get these issues known and/or on a bug list? Tnx,

    ~bd

  4. #4
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Lake Tahoe
    Posts
    9,687

    Default

    Quote Originally Posted by bdoster View Post
    exports to csv only export exactly what is on the display screen
    The bug database for NGFW is open to the public. Bug already filed. https://jira.untangle.com/browse/NGFW-12916

    Quote Originally Posted by bdoster View Post
    and changes to the report fields in one report affect all Event List reports (at least in the Network category of reports).
    I can't reproduce this. Do you have exact steps or video?
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  5. #5
    Untangler
    Join Date
    Feb 2018
    Posts
    66

    Default

    Quote Originally Posted by jcoffin View Post
    The bug database for NGFW is open to the public. Bug already filed. https://jira.untangle.com/browse/NGFW-12916
    Thank you for that. In the bug report there are 2 items mentioned... fields and data. Exports have always included only the fields displayed and that hasn't changed. It is simply the number of records being exported that is the issue. With the current (v15) implementation, the human work required for anything more than a 50,000 record report has doubled at minimum. Not to mention that the need to display 50,000 records consumes a chunk of time by itself.

    Quote Originally Posted by jcoffin View Post
    I can't reproduce this. Do you have exact steps or video?
    As of this morning it is working as expected again. I rebooted UT last night - maybe that cured the problem.

    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2