Same problem here. Recently just upgraded to 15.1.0. I put in a ticket to support. Sure they will fix it. Shows that license is active, but for some reason not applying it to the Untangle...