Ok, I'm stupid.

Anyway, spamd is running correctly, it appears. However, if I add the --allow-tell switch in the default options, I get an error saying that something is already listening on port 783 for host 127.0.0.1, and it's not spamd.

running: netstat -luntp | grep 783
gives me:

tcp 0 0 127.0.0.1:783 0.0.0.0:* LISTEN 18599/perl


This doesn't appear, to me, to be spamd.

If I change the port in the spamassassin default options to 784, I get this:

tcp 0 0 127.0.0.1:784 0.0.0.0:* LISTEN 22103/spamd.pid


Does this change cause any problems?

Also, is there any way to check and see that spamassassin is learning?