Results 1 to 6 of 6
  1. #1
    Master Untangler
    Join Date
    Feb 2009
    Posts
    171

    Default Spam blocker crashing?

    utspamblocker.PNG

    This happened today. Has happened once before. Once I turn off the Spam blocker and turn it back on, it works. What might be causing this?

    Build: 11.1.0~svn20150430r40162release11.1-1wheezy
    Kernel: 3.2.0-4-untangle-686-pae

  2. #2
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,486

    Default

    You'll need to look at the logs and see why spamassassin is not responding.

    Or contact support.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Master Untangler
    Join Date
    Feb 2009
    Posts
    171

    Default

    Here are the snippets of the logs when I think it crashed. I'm not sure. Maybe you can make something out of it.

    mail.info:
    Code:
    Jul  7 02:10:16 untangle spamd[19542]: spamd: connection from localhost [127.0.0.1] at port 5876
    Jul  7 02:10:17 untangle spamd[19542]: spamd: checking message (unknown) for spamd:10001
    Jul  7 02:10:21 untangle spamd[19542]: mailshell: Spam Blocker License Invalid: 1 at /usr/share/perl5/Mail/SpamAssassin/Plugin/MailShell.pm line 108.
    Jul  7 02:10:22 untangle spamd[19542]: spamd: identified spam (7.9/5.0) for spamd:10001 in 5.8 seconds, 10078 bytes.
    Jul  7 02:10:22 untangle spamd[19542]: spamd: result: Y 7 - BAYES_99,HTML_MESSAGE,MIME_HTML_ONLY,MISSING_MID,RCVD_IN_BRBL_LASTEXT,RP_MATCHES_RCVD,SPF_PASS,URIBL_BLACK scantime=5.8,size=10078,user=spamd,uid=10001,required_score=5.0,rhost=localhost,raddr=127.0.0.1,rport=5876,mid=(unknown),bayes=0.998713,autolearn=no
    Jul  7 02:10:46 untangle spamd[1164]: prefork: child states: IK
    Jul  7 02:14:36 untangle spamd[1164]: spamd: server hit by SIGHUP, restarting
    Jul  7 02:14:36 untangle spamd[1164]: spamd: child [19542] killed successfully: interrupted, signal 2 (0002)
    Jul  7 02:15:40 untangle spamd[1164]: Use of uninitialized value $selerr in concatenation (.) or string at /usr/share/perl5/Mail/SpamAssassin/SpamdForkScaling.pm line 332.
    Jul  7 02:15:40 untangle spamd[1164]: prefork: select returned error on server filehandle:
    mail.warn:
    Code:
    Jul  7 02:10:21 untangle spamd[19542]: mailshell: Spam Blocker License Invalid: 1 at /usr/share/perl5/Mail/SpamAssassin/Plugin/MailShell.pm line 108.
    Jul  7 02:15:40 untangle spamd[1164]: Use of uninitialized value $selerr in concatenation (.) or string at /usr/share/perl5/Mail/SpamAssassin/SpamdForkScaling.pm line 332.
    Jul  7 02:15:40 untangle spamd[1164]: prefork: select returned error on server filehandle:
    mail.log:
    Code:
    Jul  7 02:10:16 untangle spamd[19542]: spamd: connection from localhost [127.0.0.1] at port 5876
    Jul  7 02:10:17 untangle spamd[19542]: spamd: checking message (unknown) for spamd:10001
    Jul  7 02:10:21 untangle spamd[19542]: mailshell: Spam Blocker License Invalid: 1 at /usr/share/perl5/Mail/SpamAssassin/Plugin/MailShell.pm line 108.
    Jul  7 02:10:22 untangle spamd[19542]: spamd: identified spam (7.9/5.0) for spamd:10001 in 5.8 seconds, 10078 bytes.
    Jul  7 02:10:22 untangle spamd[19542]: spamd: result: Y 7 - BAYES_99,HTML_MESSAGE,MIME_HTML_ONLY,MISSING_MID,RCVD_IN_BRBL_LASTEXT,RP_MATCHES_RCVD,SPF_PASS,URIBL_BLACK scantime=5.8,size=10078,user=spamd,uid=10001,required_score=5.0,rhost=localhost,raddr=127.0.0.1,rport=5876,mid=(unknown),bayes=0.998713,autolearn=no
    Jul  7 02:10:46 untangle spamd[1164]: prefork: child states: IK
    Jul  7 02:14:36 untangle spamd[1164]: spamd: server hit by SIGHUP, restarting
    Jul  7 02:14:36 untangle spamd[1164]: spamd: child [19542] killed successfully: interrupted, signal 2 (0002)
    Jul  7 02:15:40 untangle spamd[1164]: Use of uninitialized value $selerr in concatenation (.) or string at /usr/share/perl5/Mail/SpamAssassin/SpamdForkScaling.pm line 332.
    Jul  7 02:15:40 untangle spamd[1164]: prefork: select returned error on server filehandle:

  4. #4
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,546

    Default

    I would just turn on remote support and open a ticket.

    Also, look in /var/log/uvm, are there any *.crash files?
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  5. #5
    Master Untangler
    Join Date
    Feb 2009
    Posts
    171

    Default

    Nope. No crash files here. And the symptom was exactly as you described on your post on the Spam blocker thread. No incoming email. After turning off and on the spam blocker lite, everything is good.
    Last edited by sa_un; 07-07-2015 at 02:02 PM.

  6. #6
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,546

    Default

    Usually when I see a box that's not passing mail it's due to a defective hard disk. But, if that was the case a simple reboot would brick the thing. Your situation is different, and you can either dig in and figure out what's up with spam assassin, or let UT support handle it.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2