Page 11 of 15 FirstFirst ... 910111213 ... LastLast
Results 101 to 110 of 146
  1. #101
    Untangler
    Join Date
    Apr 2008
    Posts
    71

    Default

    Here you go:

    This was done with Opera, so the "x" marks are hard to see. But you see the small check marks.

    (corrected)
    Lowen
    Last edited by Lowen; 09-23-2008 at 06:01 PM.

  2. #102
    Untangler
    Join Date
    Apr 2008
    Posts
    71

    Default

    Oh I have a question regarding security and bridging the wifi to the lan. Since this concept puts the wifi on the lan, doesn't it post as a security threat? Especialy since it is on the same lan segment. If the wireless is compromised, then an attacker would have access to the whole network!!!


    Lowen
    Last edited by Lowen; 09-23-2008 at 06:26 PM.

  3. #103
    Untangle Ninja Silver Bullet's Avatar
    Join Date
    Sep 2007
    Posts
    1,946

    Default

    You don't have to bridge it if you want to keep wireless completely separate from the LAN. I initially ran mine bridged but changed it to a stand alone interface to see if I could. It works fine.

    I am almost to the point to installing my wireless on my new build and I will post how I made it a stand alone interface. I could probably post it from memory, but want to make sure that I don't leave anything out. The only thing different is the interfaces file, hostapd.conf and manually editing dnsmasq which you are already familiar with.

    P.S. I am going to change that port forward up a bit... standby!
    Vote here to have wireless included in Untangle.

  4. #104
    Untangle Ninja Silver Bullet's Avatar
    Join Date
    Sep 2007
    Posts
    1,946

    Default

    Ok... I am up and running

    Lowen, I was able to dup that block page problem. Leave the port forward just as is and create a packet filter rule that matches this and you should start getting your block page.


    To make your access point a separate interface, first go to alpaca and set it to static and set your ip address that you want that interface to be... different subnet. Then create a NAT rule for 0.0.0.0/0 and leave the interface set to auto.

    Then go to /etc/network/interfaces and make sure that your interfaces file looks like so... make sure the br.eth1 stuff isn't there. I noticed that you have an additional interface... make sure that it's params are there too.
    Code:
    ## Tue Sep 23 20:48:17 -0500 2008
    ## Auto Generated by the Untangle Net Alpaca
    ## If you modify this file manually, your changes
    ## may be overriden
    
    auto cleanup
    iface cleanup inet manual
    
    ## Configuration for the loopback interface
    auto lo
    iface lo inet loopback
    
    
    auto eth0
    iface eth0 inet dhcp
            mtu 1500
    
    auto ath0
    iface ath0 inet static
            address 172.20.2.1
            netmask 255.255.255.0
            pre-up wlanconfig ath0 destroy
            pre-up wlanconfig ath0 create wlandev wifi0 wlanmode ap
            post-down wlanconfig ath0 destroy
            pre-up iwconfig ath0 channel 1
            wireless-mode master
    
    auto eth1
    iface eth1 inet static
            address 172.20.1.1
            netmask 255.255.255.0
            mtu 1500
    
    ## This will run any scripts that need to execute when the address changes.
    auto update
    iface update inet manual
    Then, make your dnsmasq changes to suit. Here is my dnsmasq.conf
    Code:
    ## Tue Sep 23 22:00:19 -0500 2008
    ## Auto Generated by the Untangle Net Alpaca
    ## If you modify this file manually, your changes
    ## may be overriden
    
    dhcp-range=172.20.1.50,172.20.1.70,14400
    dhcp-range=ath0,172.20.2.50,172.20.2.70,14400
    dhcp-option=ath0,3,172.20.2.1
    dhcp-option=3,172.20.1.1
    dhcp-option=1,255.255.255.0
    
    dhcp-host=00:11:d8:50:7a:3f,172.20.1.3,24h
    dhcp-host=00:0b:cd:b4:37:b1,Cisco,172.20.1.30,24h
    dhcp-host=ath0,00:0e:7f:a8:66:5c,aphrodite,172.20.2.3,24h
    
    localise-queries
    expand-hosts
    addn-hosts=/etc/untangle-net-alpaca/dnsmasq-hosts
    no-hosts
    domain=home.local
    domain-suffix=home.local
    
    server=xxx.xxx.xxx.xxx
    server=xxx.xxx.xxx.xxx
    Let me know how that works for you!

    P.S. I know that you and I have talked about it before and I just tested it again. I had to create a packet filter rule to get DNS to my wireless client.
    Vote here to have wireless included in Untangle.

  5. #105
    Untangler
    Join Date
    Apr 2008
    Posts
    71

    Default

    I am not getting a SSID, it is blank! I believe it lays in the hostapd.conf

    Code:
    interface=ath0
    bridge=br.eth1
    I removed the : bridge=br.eth1(since we are no longer bridging), but it still gets no SSID.
    I figured since you didn't mention the hostapd. conf, it didn't need to be changed....

    I appreciate your efforts.

    Lowen

  6. #106
    Untangle Ninja Silver Bullet's Avatar
    Join Date
    Sep 2007
    Posts
    1,946

    Default

    Did you restart hostapd after you edited hostapd.conf to remove the bridge info?
    Code:
    /etc/init.d/hostapd restart
    Can you post your interfaces file again?

    I did mean to mention that you need to remove the bridge param from hostapd.conf. Looks like you figured it out anyway.
    Vote here to have wireless included in Untangle.

  7. #107
    Untangler
    Join Date
    Apr 2008
    Posts
    71

    Default

    Here is the interface file:

    Code:
    auto eth0
    iface eth0 inet dhcp
    	mtu 1500
    
    auto ath0
    iface ath0 inet static
            address 192.168.2.1
            netmask 255.255.255.0
            pre-up wlanconfig ath0 destroy
            pre-up wlanconfig ath0 create wlandev wifi0 wlanmode ap
            post-down wlanconfig ath0 destroy
            pre-up iwconfig ath0 channel 1
            wireless-mode master
    
    auto eth1
    iface eth1 inet static
    	address 192.168.1.1
    	netmask 255.255.255.0
    	mtu 1500
    
    
    auto eth2
    iface eth2 inet static
    	address 192.168.5.1
    	netmask 255.255.255.0
    	mtu 1500

    Regards
    Lowen

  8. #108
    Untangler
    Join Date
    Apr 2008
    Posts
    71

    Default

    It seems to be up and running after I shutdown the box. Block page is also properly formatted. I appreciate your efforts. Working well! Now if we could get the WPA key to rotate out from the server to the clients automatically would be one of those "cool things" you were talking about! :P

    Regards,
    Lowen

  9. #109
    Untangle Ninja Silver Bullet's Avatar
    Join Date
    Sep 2007
    Posts
    1,946

    Default

    I guess I took for granted that you would reboot.

    Glad you got it going
    Vote here to have wireless included in Untangle.

  10. #110
    Untangler
    Join Date
    Apr 2008
    Posts
    71

    Default

    Thanks again! I had to create a block rule from wifi to LAN though. I didn't like the idea of the wifi clients being able to connect to the internal network.

    Regards,
    Lowen

Page 11 of 15 FirstFirst ... 910111213 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2